Bug #34571 redundant program in Windows uninstall menu
Submitted: 14 Feb 2008 22:28 Modified: 14 Jul 2008 9:22
Reporter: Peter Laursen (Basic Quality Contributor) Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / ODBC Severity:S3 (Non-critical)
Version: OS:Microsoft Windows (Vista 32 bit)
Assigned to: CPU Architecture:Any

[14 Feb 2008 22:28] Peter Laursen
Description:
Installing MyODBC 5.1.2 on top of 5.1.1 adds a redundant icon to the uninstall menu in Windows Control Panel

How to repeat:
see attached image

Suggested fix:
Test packages on Vista and fix all those annoying installer issues on Windows Vista!
[14 Feb 2008 22:29] Peter Laursen
redundant MyODBC 5.1 entry in uninstall menu

Attachment: myodbc.gif (image/gif, text), 10.97 KiB.

[16 Feb 2008 16:08] Tonci Grgin
Hi Peter and thanks for your report. Can you please test with latest release, 5.1.2.? I tested and found no problems...

Waiting on your results.
[16 Feb 2008 16:47] Peter Laursen
That was what I did acutally.  Installed 5.1.2 on top of 5.1.1.
This could be an old issue from installing 5.1.1 on top of 5.1.0 however. 

I will 
1) uninstall and if required clean the registry for all entries
2) install 5.1.1
3) install 5.1.2

and report back!
[16 Feb 2008 18:12] Tonci Grgin
Peter, thank you. Waiting on your results.
[16 Feb 2008 21:15] Peter Laursen
reproduced.

One change however.  I installed 5.1.2 on top of 5.1.0.

After first report I uninstalled the driver.  One entry in uninstall menu disappeared (as expected).  Trying to uninstall the other one returned 'action only valid for installed programs'. After seacrhing registry for "odbc 5.1" and delteing everything related (there was quite a lot actually) the orphaned entry disappeared from uninstall menu.  Now installed MyODBC 5.1.0.  One entry in uninstall menu appeared.  Next installed 5.1.2  Now two entries are there!

Actually I found that I have a Microsoft program that did the same! 

One 'sideeffect' is that after uninstalling the driver still appeared in 'computer management .. odbc' .. but not functional of course!
[16 Feb 2008 21:17] Peter Laursen
one more time redundant entry in uninstall menu

Attachment: odbc.gif (image/gif, text), 4.97 KiB.

[16 Feb 2008 22:03] Jess Balint
Was 5.1.0 using the wix-2 installer? Maybe this was a problem with wix-2 or having  the wix-3 installer correctly update the installation.
[18 Feb 2008 8:11] Tonci Grgin
Hi Peter. Can you please do as Jess asked and test only install/uninstall of 5.1.2? There were changes in installer which might have fixed this. Did you do install/uninstall from privileged account? I tried this during my normal work and found no problems, but I only have Vista x64 business.
[18 Feb 2008 8:57] Peter Laursen
I can try .. but may take up to a couple of days.
[18 Feb 2008 10:52] Tonci Grgin
Peter, waiting on your result.
[18 Feb 2008 11:45] Peter Laursen
I uninstalled and removed everthing related to MyODBC 5.1 and 3.51, rebooted, installed both, uninstalled both, rebooted.

Now from a user's point of view it is (almost) OK.

However there still are obsolete registry entries after uninstall.  I attach those as a zipped archive.

Also I am not able to verify that every file is properly deleted as I do not know what files are copied and where.  I think you should verify!

I still think it is a BUG that *upgrading* does not clean up garbage from previous versions!
[18 Feb 2008 11:48] Peter Laursen
=bsolete registry keys after 5.1.2 and 3.51.21 uninstall

Attachment: regkeys.zip (application/zip, text), 603 bytes.

[18 Feb 2008 11:48] Peter Laursen
*obsolete* .. of course!
[18 Feb 2008 12:21] Peter Laursen
alternatively ...

If 5.1.2 cannot clean up after 5.1.0 then it should refuse to install and prompt user that 5.1.0 must be uninstalled manually first.
[19 Feb 2008 13:02] Tonci Grgin
Peter, I just checked my Vista Ultimate x64 and could not repeat your problem... I don't say it does not exist but that's the reason we have alpha / beta etc releases. As far as I know, installer version changed from 2 to 3 between alpha and beta so problems like this might be expected. However I'll set this problem to "Verified" so our doc-master, MC, can add a line or two of warning.

Thanks for your interest in MySQL.
[19 Feb 2008 13:18] Peter Laursen
ok ...

I think that my screenshots are undisputable!?

But if it does not happen all time, I do not know what triggers this.

It is not a big issue.  But basically I think that MySQL AB should focus more on/test with Vista.  Install .. use .. uninstall.  I have another report with installer issues on Vista open. Also a few days ago I installed server 5.1.23 and latest connector .NET.  Also those had some small issues with the installer on this system.  What I remember:

* installer for 5.1 server was not able to stop or start running service
* one of those installers printed outside the dialogue box.

Maybe however I should have told that my OS is Vista 32 bit SP1 (RC).
Hardware Athlon Dual Core 64 bit (a HP series 9xxx laptop), Graphics is a typical Nvidia system for laptops.

I find small issues with practically every recent installer for Windows.  And that was not so a few years ago!
[19 Feb 2008 14:10] Tonci Grgin
Hi Peter.

> I think that my screenshots are undisputable!?

Yes, I can't tell you you're imagining this :) although I can't repeat.

> But if it does not happen all time, I do not know what triggers this.

Neither do we. I asked doc-team to add a warning.

> It is not a big issue.  But basically I think that MySQL AB should focus more on/test with Vista.  Install .. use .. uninstall.  I have another report with installer issues on Vista open. Also a few days ago I installed server 5.1.23 and latest connector .NET.  Also those had some small issues with the installer on this system.  What I remember:
* installer for 5.1 server was not able to stop or start running service
* one of those installers printed outside the dialogue box.

Well, we are committed to making things as best as possible, but a minor errors are bound to happen. We don't like that, be it even half baked soon-to-be-dead "shiny" new OS from you know who.

> Maybe however I should have told that my OS is Vista 32 bit SP1 (RC).
Hardware Athlon Dual Core 64 bit (a HP series 9xxx laptop), Graphics is a typical Nvidia system for laptops.

Ok, I tested on Athlon x64 + nVIDIA too but with Vista Ultimate x64.

> I find small issues with practically every recent installer for Windows.  And that was not so a few years ago!

We have changed several installers lately in search for one that suits us best and we're not yet familiar with all the features / tricks.
[17 Mar 2008 8:25] Tonci Grgin
My colleagues have failed to repeat the problem on Vista business 32bit...
"But bug is not repeatable for me too: I get warning about another version of the product installed and installer quits."

I will let Georg close this as he sees fit.
[14 Jul 2008 9:22] Susanne Ebrecht
This is a duplicate of bug #4217.