Bug #34522 Unable to install 5.1.1
Submitted: 13 Feb 2008 14:07 Modified: 1 Mar 2008 11:40
Reporter: Kerry Kurtz Email Updates:
Status: Closed Impact on me:
None 
Category:Connector / ODBC Severity:S1 (Critical)
Version: OS:Microsoft Windows (WinXP Pro)
Assigned to: Georg Richter
Tags: 5.1, connector, install, ODBC
Triage: D2 (Serious)

[13 Feb 2008 14:07] Kerry Kurtz
Description:
I am unable to get the latest Connector/ODBC installed. Near the end of the installation the installer gives the following error:
-> A network error occurred while attempting to read from file
-> C:\Downloads\software\MyODBC-3.51.11-2-win.msi
At first I thought I had a corrupted download, but after several downloads from different mirrors all resulting in the same error the conclusion is that it was a problem in the build, or upload to the mirrors, therefore the reason for this bug report.

How to repeat:
Download the .msi installer and try to install, picking one of the US mirrors for the download.
[13 Feb 2008 14:30] Kerry Kurtz
I just verified the md5 checksum so the problem is definitely in the build
[26 Feb 2008 10:45] Tonci Grgin
Kerry, glad your problem is solved.

Thanks for your interest in MySQL.
[26 Feb 2008 13:11] Kerry Kurtz
So, what resolved the problem? I still have it, the md5 signature matches, the download(s from multiple mirrors) all fail with the reported error
[26 Feb 2008 13:23] Tonci Grgin
Kerry, sorry I misread your post... Did you try with 5.1.2? As for me I can't repeat this problem even though I installed it on many systems.
[27 Feb 2008 8:04] Tonci Grgin
Hi Kerry. I checked msi-s for both 5.1.1 and 5.1.2 and found what appears the cause of problem... Property.QualifiedProductName == MySQL Connector/ODBC 3.51.11 thus, probably, install/uninstall is trying to use old info in registry, and failing. There might be some other hard-coded stuff there too.

I have informed Kent and Georg of this problem.
[27 Feb 2008 8:17] Georg Richter
Fix for msi installer

Attachment: bug34522.diff (text/x-patch), 611 bytes.

[27 Feb 2008 17:34] Jim Winstead
Kent committed the fix, so I assume that means he thought it was okay.
[1 Mar 2008 11:40] MC Brown
A note has been added to the 5.1.3 changelog: 

Installation of Connector/ODBC would fail because it was unable to uninstall a previous installed version. The file being requested would match an older release version than any installed version of the connector.