Bug #34221 Add Diagramm leads to Exception/Crash (with Hardware OpenGL)
Submitted: 1 Feb 2008 10:43 Modified: 28 Feb 2008 13:20
Reporter: Bruno Baketaric Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S1 (Critical)
Version:5.0.14a OS:Microsoft Windows (XP, Intel Grafics)
Assigned to: CPU Architecture:Any

[1 Feb 2008 10:43] Bruno Baketaric
Description:
When using the Hardware accelerated OpenGL Version on my Intel 965 Grafics based Desktop (latest Intel Drivers, OpenGL 1.5 100% supported according to OpenGL Extensions viewer), Workbench crashes as soon as a Diagram is opened. Software Rendering works, but is horribly slow - impossible to work with, if you have a Model with 40+ Tables and nearly the same amount of relations. 

Here's the Crash-Report:

Informationen über das Aufrufen von JIT-Debuggen
anstelle dieses Dialogfelds finden Sie am Ende dieser Meldung.

************** Ausnahmetext **************
System.AccessViolationException: Es wurde versucht, im geschützten Speicher zu lesen oder zu schreiben. Dies ist häufig ein Hinweis darauf, dass anderer Speicher beschädigt ist.
   bei MySQL.GUI.Mdc.BaseWindowsCanvasView.OnSizeChanged(Int32 w, Int32 h)
   bei MySQL.Utilities.WindowsCanvasViewerPanel.OnSizeChanged(EventArgs e)
   bei System.Windows.Forms.Control.UpdateBounds(Int32 x, Int32 y, Int32 width, Int32 height, Int32 clientWidth, Int32 clientHeight)
   bei System.Windows.Forms.Control.UpdateBounds()
   bei System.Windows.Forms.Control.WmWindowPosChanged(Message& m)
   bei System.Windows.Forms.Control.WndProc(Message& m)
   bei System.Windows.Forms.ScrollableControl.WndProc(Message& m)
   bei MySQL.Utilities.WindowsCanvasViewerPanel.WndProc(Message& msg)
   bei System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   bei System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   bei System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

************** Geladene Assemblys **************
mscorlib
    Assembly-Version: 2.0.0.0.
    Win32-Version: 2.0.50727.1433 (REDBITS.050727-1400).
    CodeBase: file:///c:/WINDOWS/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll.
----------------------------------------
MySQLWorkbench
    Assembly-Version: 5.0.12.2434.
    Win32-Version: 5.0.12.2434.
    CodeBase: file:///C:/Programme/MySQL/MySQL%20Workbench/MySQLWorkbench.exe.
----------------------------------------
wb.wr
    Assembly-Version: 0.0.0.0.
    Win32-Version: .
    CodeBase: file:///C:/Programme/MySQL/MySQL%20Workbench/wb.wr.DLL.
----------------------------------------
grt.wr
    Assembly-Version: 0.0.0.0.
    Win32-Version: .
    CodeBase: file:///C:/Programme/MySQL/MySQL%20Workbench/grt.wr.DLL.
----------------------------------------
MySQLCsUtilities
    Assembly-Version: 1.0.0.0.
    Win32-Version: 1.0.0.0.
    CodeBase: file:///C:/Programme/MySQL/MySQL%20Workbench/MySQLCsUtilities.DLL.
----------------------------------------
msvcm80
    Assembly-Version: 8.0.50727.1433.
    Win32-Version: 8.00.50727.1433.
    CodeBase: file:///C:/WINDOWS/WinSxS/x86_Microsoft.VC80.CRT_1fc8b3b9a1e18e3b_8.0.50727.1433_x-ww_5cf844d2/msvcm80.dll.
----------------------------------------
MySQLGrtShell
    Assembly-Version: 1.0.0.0.
    Win32-Version: 1.0.0.0.
    CodeBase: file:///C:/Programme/MySQL/MySQL%20Workbench/MySQLGrtShell.EXE.
----------------------------------------
System.Windows.Forms
    Assembly-Version: 2.0.0.0.
    Win32-Version: 2.0.50727.1433 (REDBITS.050727-1400).
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll.
----------------------------------------
System
    Assembly-Version: 2.0.0.0.
    Win32-Version: 2.0.50727.1433 (REDBITS.050727-1400).
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll.
----------------------------------------
System.Drawing
    Assembly-Version: 2.0.0.0.
    Win32-Version: 2.0.50727.1433 (REDBITS.050727-1400).
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll.
----------------------------------------
WeifenLuo.WinFormsUI.Docking
    Assembly-Version: 2.0.0.0.
    Win32-Version: 2.0.0.0.
    CodeBase: file:///C:/Programme/MySQL/MySQL%20Workbench/WeifenLuo.WinFormsUI.Docking.DLL.
----------------------------------------
System.Xml
    Assembly-Version: 2.0.0.0.
    Win32-Version: 2.0.50727.1433 (REDBITS.050727-1400).
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll.
----------------------------------------
mscorlib.resources
    Assembly-Version: 2.0.0.0.
    Win32-Version: 2.0.50727.1433 (REDBITS.050727-1400).
    CodeBase: file:///c:/WINDOWS/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll.
----------------------------------------
MySQLWorkbenchEditors
    Assembly-Version: 1.0.0.0.
    Win32-Version: 1.0.0.0.
    CodeBase: file:///C:/Programme/MySQL/MySQL%20Workbench/MySQLWorkbenchEditors.DLL.
----------------------------------------
Aga.Controls
    Assembly-Version: 1.6.0.0.
    Win32-Version: 1.6.0.0.
    CodeBase: file:///C:/Programme/MySQL/MySQL%20Workbench/Aga.Controls.DLL.
----------------------------------------
grt.helpers.be
    Assembly-Version: 1.0.0.0.
    Win32-Version: 1.0.0.0.
    CodeBase: file:///C:/Programme/MySQL/MySQL%20Workbench/grt.helpers.be.DLL.
----------------------------------------
System.Windows.Forms.resources
    Assembly-Version: 2.0.0.0.
    Win32-Version: 2.0.50727.1433 (REDBITS.050727-1400).
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Windows.Forms.resources/2.0.0.0_de_b77a5c561934e089/System.Windows.Forms.resources.dll.
----------------------------------------

************** JIT-Debuggen **************
Um das JIT-Debuggen (Just-In-Time) zu aktivieren, muss in der
Konfigurationsdatei der Anwendung oder des Computers
(machine.config) der jitDebugging-Wert im Abschnitt system.windows.forms festgelegt werden.
Die Anwendung muss mit aktiviertem Debuggen kompiliert werden.

Zum Beispiel:

<configuration>
    <system.windows.forms jitDebugging="true" />
</configuration>

Wenn das JIT-Debuggen aktiviert ist, werden alle nicht behandelten
Ausnahmen an den JIT-Debugger gesendet, der auf dem
Computer registriert ist, und nicht in diesem Dialogfeld behandelt.

How to repeat:
- Start Workbench
- Click "Add Diagram".

or

- Start Workbench
- import SQL-Create Script
- Select "Model -> Create Diagram from ..."
[4 Feb 2008 13:49] Miguel Solorzano
Thank you for the bug report. Could you please provide (private if you wish)
the model file which shows the slowness of Workbench?. Thanks in advance.
[4 Feb 2008 15:39] Bruno Baketaric
Hi Miguel, I don't believe, the model itself is the problem here. If you have a model with many tables and relations, and updating the Diagram takes a 250 msec. (software rendering), if you just hover your mouse over a relation-line, you don't really want to work with the Workbench anymore. 
The fix should be to get hardware rendering working with the Intel Chipset.

Regards,
Bruno
[8 Feb 2008 4:19] Valeriy Kravchuk
Please, try to repeat with a newer version, 5.0.13, and inform about the results.
[8 Feb 2008 8:43] Bruno Baketaric
Still the same result.

Here's the Debugger Dump again:
_________________________________

Informationen über das Aufrufen von JIT-Debuggen
anstelle dieses Dialogfelds finden Sie am Ende dieser Meldung.

************** Ausnahmetext **************
System.AccessViolationException: Es wurde versucht, im geschützten Speicher zu lesen oder zu schreiben. Dies ist häufig ein Hinweis darauf, dass anderer Speicher beschädigt ist.
   bei MySQL.GUI.Mdc.BaseWindowsCanvasView.OnSizeChanged(Int32 w, Int32 h)
   bei MySQL.Utilities.WindowsCanvasViewerPanel.OnSizeChanged(EventArgs e)
   bei System.Windows.Forms.Control.UpdateBounds(Int32 x, Int32 y, Int32 width, Int32 height, Int32 clientWidth, Int32 clientHeight)
   bei System.Windows.Forms.Control.UpdateBounds()
   bei System.Windows.Forms.Control.WmWindowPosChanged(Message& m)
   bei System.Windows.Forms.Control.WndProc(Message& m)
   bei System.Windows.Forms.ScrollableControl.WndProc(Message& m)
   bei MySQL.Utilities.WindowsCanvasViewerPanel.WndProc(Message& msg)
   bei System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   bei System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   bei System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

************** Geladene Assemblys **************
mscorlib
    Assembly-Version: 2.0.0.0.
    Win32-Version: 2.0.50727.1433 (REDBITS.050727-1400).
    CodeBase: file:///c:/WINDOWS/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll.
----------------------------------------
MySQLWorkbench
    Assembly-Version: 5.0.13.2541.
    Win32-Version: 5.0.13.2541.
    CodeBase: file:///C:/Programme/MySQL/MySQL%20Workbench/MySQLWorkbench.exe.
----------------------------------------
wb.wr
    Assembly-Version: 0.0.0.0.
    Win32-Version: .
    CodeBase: file:///C:/Programme/MySQL/MySQL%20Workbench/wb.wr.DLL.
----------------------------------------
grt.wr
    Assembly-Version: 0.0.0.0.
    Win32-Version: .
    CodeBase: file:///C:/Programme/MySQL/MySQL%20Workbench/grt.wr.DLL.
----------------------------------------
System.Windows.Forms
    Assembly-Version: 2.0.0.0.
    Win32-Version: 2.0.50727.1433 (REDBITS.050727-1400).
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll.
----------------------------------------
System
    Assembly-Version: 2.0.0.0.
    Win32-Version: 2.0.50727.1433 (REDBITS.050727-1400).
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll.
----------------------------------------
System.Drawing
    Assembly-Version: 2.0.0.0.
    Win32-Version: 2.0.50727.1433 (REDBITS.050727-1400).
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll.
----------------------------------------
MySQLCsUtilities
    Assembly-Version: 1.0.0.0.
    Win32-Version: 1.0.0.0.
    CodeBase: file:///C:/Programme/MySQL/MySQL%20Workbench/MySQLCsUtilities.DLL.
----------------------------------------
msvcm80
    Assembly-Version: 8.0.50727.1433.
    Win32-Version: 8.00.50727.1433.
    CodeBase: file:///C:/WINDOWS/WinSxS/x86_Microsoft.VC80.CRT_1fc8b3b9a1e18e3b_8.0.50727.1433_x-ww_5cf844d2/msvcm80.dll.
----------------------------------------
MySQLGrtShell
    Assembly-Version: 1.0.0.0.
    Win32-Version: 1.0.0.0.
    CodeBase: file:///C:/Programme/MySQL/MySQL%20Workbench/MySQLGrtShell.EXE.
----------------------------------------
WeifenLuo.WinFormsUI.Docking
    Assembly-Version: 2.0.0.0.
    Win32-Version: 2.0.0.0.
    CodeBase: file:///C:/Programme/MySQL/MySQL%20Workbench/WeifenLuo.WinFormsUI.Docking.DLL.
----------------------------------------
System.Xml
    Assembly-Version: 2.0.0.0.
    Win32-Version: 2.0.50727.1433 (REDBITS.050727-1400).
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll.
----------------------------------------
mscorlib.resources
    Assembly-Version: 2.0.0.0.
    Win32-Version: 2.0.50727.1433 (REDBITS.050727-1400).
    CodeBase: file:///c:/WINDOWS/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll.
----------------------------------------
MySQLWorkbenchEditors
    Assembly-Version: 1.0.0.0.
    Win32-Version: 1.0.0.0.
    CodeBase: file:///C:/Programme/MySQL/MySQL%20Workbench/MySQLWorkbenchEditors.DLL.
----------------------------------------
Aga.Controls
    Assembly-Version: 1.6.0.0.
    Win32-Version: 1.6.0.0.
    CodeBase: file:///C:/Programme/MySQL/MySQL%20Workbench/Aga.Controls.DLL.
----------------------------------------
grt.helpers.be
    Assembly-Version: 1.0.0.0.
    Win32-Version: 1.0.0.0.
    CodeBase: file:///C:/Programme/MySQL/MySQL%20Workbench/grt.helpers.be.DLL.
----------------------------------------
System.Windows.Forms.resources
    Assembly-Version: 2.0.0.0.
    Win32-Version: 2.0.50727.1433 (REDBITS.050727-1400).
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Windows.Forms.resources/2.0.0.0_de_b77a5c561934e089/System.Windows.Forms.resources.dll.
----------------------------------------

************** JIT-Debuggen **************
Um das JIT-Debuggen (Just-In-Time) zu aktivieren, muss in der
Konfigurationsdatei der Anwendung oder des Computers
(machine.config) der jitDebugging-Wert im Abschnitt system.windows.forms festgelegt werden.
Die Anwendung muss mit aktiviertem Debuggen kompiliert werden.

Zum Beispiel:

<configuration>
    <system.windows.forms jitDebugging="true" />
</configuration>

Wenn das JIT-Debuggen aktiviert ist, werden alle nicht behandelten
Ausnahmen an den JIT-Debugger gesendet, der auf dem
Computer registriert ist, und nicht in diesem Dialogfeld behandelt.

_______________________________________________

And the Error-Popup says: 

"Unknown Exception caught in c:\documents and settings\mysqldev\my documents\visual studio 2005\projects\mysql-workbench-pro\backend\windows\wb.wr\srv\Canvas.h at line 142"

Software-Rendering works, initial positioning of the Tables and relations is much faster now, but hovering over a relation or dragging a table around is still too slow to really work with it.
[14 Feb 2008 7:28] Sven Mohr
I guess it is the same problem, which has been reported in bug report #34403.
[14 Feb 2008 7:41] Bruno Baketaric
I agree, looks very similar. Same Error Location (Canvas.h) and the same Grafics Chipset.
[24 Feb 2008 18:23] Valeriy Kravchuk
Duplicate of Bug #34403.
[28 Feb 2008 12:29] Lies Depuydt
In MySQL Workbench 5.0 OSS (Software Rendering) 
no problem anymore after download version 5.0.14a 

(I'm using Windows Vista Business)
[28 Feb 2008 13:16] Bruno Baketaric
5.0.14a still crashes with Hardware-Rendering, but Software rendering is much faster now. At least it seems to be fast enough to work with the Workbench.
[28 Feb 2008 13:20] Bruno Baketaric
Well, my comment before was wrong. Initially it worked, but after some successful tries, Workbench started crashing again - in Hardware and Software rendering mode.