Bug #34200 Using the "--help" option displays "***unknown variable forcewrapping***"
Submitted: 31 Jan 2008 17:18 Modified: 16 Jun 2008 19:14
Reporter: Peter Lavin Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Enterprise Monitor: Installing Severity:S3 (Non-critical)
Version:1.3.0.8910, 0.7.0.707 OS:Any
Assigned to: BitRock Merlin CPU Architecture:Any
Tags: checkmysqlhost, forcewrapping

[31 Jan 2008 17:18] Peter Lavin
Description:
When running the agent installer with the "--help" option the following message is displayed:

...
 --checkmysqlhost <checkmysqlhost> Validate MySQL hostname or IP addre
ss***unknown variable forcewrapping***
                                Default: yes
...

How to repeat:
See above.

Suggested fix:
Define thus variable?
[31 Jan 2008 17:55] Peter Lavin
Wasn't there a usage message if you typed an incorrect option? Typing a non-existent option now shows no usage message.
[31 Jan 2008 18:06] Carsten Segieth
change OS to 'Any', as the problem appears also on Linux-x86, Solaris and HP and Windows.
[31 Jan 2008 18:09] BitRock Merlin
The installer not showing usage info is a known bug (only reproduced on Linux x64), you can see it on #32618: agent and server install x86_64 does not show message for wrong option.
[6 Feb 2008 23:22] Andy Bang
BitRock,

I believe the bug being reported here is that the text "***unknown variable forcewrapping***" appears near the --checkmysqlhost parameter definition.  Either this text should be removed or perhaps the "forcewrapping" variable should be documented.
[7 Feb 2008 19:22] BitRock Merlin
Patch sent to Keith.
[8 Feb 2008 23:48] Keith Russell
Patch applied in revisions => 8910.
[12 Feb 2008 13:28] Carsten Segieth
*not solved* in 1.3.0.8910, checked with generic Linux installer package for/on RH4_x86 (net-qa1):

<INSTALLER> --help
MySQL Enterprise Service Agent 1.3.0.8910
Usage:

...
 --installer-language <installer-language> Language selection
                                Default:
                                Allowed: en jp

 --installdir <installdir>      Installation directory
                                Default:

 --mysqlhost <mysqlhost>        MySQL hostname or IP address
                                Default: 127.0.0.1

 --checkmysqlhost <checkmysqlhost> Validate MySQL hostname or IP address***unknown variable forcewrapping***
                                Default: yes
...
[13 Feb 2008 9:53] BitRock Merlin
We provided a fix only for version 2.0, following the "Target Version" field, which is set to "2.0" for this case. We could as well provide a fix for version 1.3, just let us know in case you want us to do so.
[14 Feb 2008 17:35] Andy Bang
We are in final beta for 1.3 and want to take as few changes as possible, so this is targeted at the 2.0 release as BitRock says.  Please test with the next 2.0 build you get.
[26 Feb 2008 20:38] Keith Russell
Patch applied in build revisions => 8933
[28 Feb 2008 14:53] Keith Russell
My apologies. This should not have been set to "QA Testing" for the recent 1.3 build. This is a patch for version 2.0 and will be applied with the next 2.0 build.
[29 May 2008 16:08] BitRock Merlin
Patch sent to Keith
[4 Jun 2008 16:33] Keith Russell
Patch installed in versions => 0.7.0.756.
[11 Jun 2008 20:14] Carsten Segieth
tested OK in agent 2.0 (0.7.0.781)
[16 Jun 2008 19:14] Paul Dubois
Noted in 2.0 changelog.

Running the installer with the --help option caused an incorrect
message to be displayed.