Bug #341 ConnectorJ doesn't work propertly with IBM JDK 1.4
Submitted: 28 Apr 2003 13:28 Modified: 28 Apr 2003 14:04
Reporter: Chris Book Email Updates:
Status: Closed Impact on me:
Category:Connector / J Severity:S1 (Critical)
Version:3.0.6 Stable OS:Linux (Linux)
Assigned to: CPU Architecture:Any

[28 Apr 2003 13:28] Chris Book
Database queries always fail when using IBM's JDK (1.4).  The same environment work's perfectly with all of Sun's implementations.

An SQL error is always returned as follows:
java.sql.SQLException: Column 'id' not found.

The error will occur for any column queried.  I havn't been able to perform a select statement that works.

How to repeat:
Tomcat 4.1.24
Connectorj 3.0.6
MySQL 4.0.10

Try running a db web application using IBM's JDK.

Suggested fix:
A workaround would be to use Sun's implementation... but that's not always an option.
[28 Apr 2003 13:39] Mark Matthews
Have you tried 3.0.7? 3.0.6 had character set issues with non-Sun JDKs, and this was fixed in 3.0.7.
[28 Apr 2003 14:02] Chris Book
I just tried 3.0.7 and the bug IS fixed.

[28 Apr 2003 14:04] Mark Matthews
Fixed in 3.0.7