Bug #34060 mysql_upgrade needs --local option
Submitted: 25 Jan 2008 15:51 Modified: 4 Oct 2010 8:54
Reporter: Morgan Tocker Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Command-line Clients Severity:S3 (Non-critical)
Version:5.0.54 OS:Any
Assigned to: CPU Architecture:Any
Triage: Triaged: D5 (Feature request) / R2 (Low)

[25 Jan 2008 15:51] Morgan Tocker
Description:
When the mysql_upgrade script runs, it performs a number of ALTER table statements.  If the mysql_upgrade has already been run on the slave, then it can result in duplicate column errors.

Many people do any upgrades etc to slaves first, so this is kind of annoying.  It's also unknown how many events need to be skipped with SQL_SLAVE_SKIP_COUNTER.

How to repeat:
Use mysql upgrade on slave, then use it on master.

Suggested fix:
Add a --local option to mysql_upgrade to disable binary logging for the session it executes in.
[4 Oct 2010 8:54] Susanne Ebrecht
This is a duplicate of bug #46638
[4 Oct 2010 9:11] Susanne Ebrecht
Sorry, wrong bug number.

This is a duplcate of bug #43579