Bug #33924 The default notation style is always Crow's Feet
Submitted: 18 Jan 2008 16:28 Modified: 18 Mar 2008 5:33
Reporter: Peter Lavin Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Workbench Severity:S4 (Feature request)
Version:5.0.12 OS:Microsoft Windows
Assigned to: CPU Architecture:Any
Tags: notation style

[18 Jan 2008 16:28] Peter Lavin
Description:
Currently, the relationship notation style that you choose persists for the duration of your MySQL Workbench session and is saved along with your model. When MySQL Workbench is restarted, the relationship notation reverts to the default, the Crow's Feet style. It would be nice to be able to set another style as the default.

How to repeat:
See above.

Suggested fix:
See above.
[28 Jan 2008 23:13] Peter Lavin
It looks like this feature is already available using the "Advanced" tab of the "MySQL Options". Can someone confirm that the following values:

crowsfeet
classic
uml
idef1x

are legitimate values for "DefaultConnectionNotation". 

Likewise with "DefaultFigureNotation". Thanks.
[18 Mar 2008 5:33] Alfredo Kojima
Default*Notation applies only to new models, not the current one.
If I change the notation in advanced and restart in a new model, it works as expected.