Bug #33875 Access Violation in MYODBC5.DLL
Submitted: 15 Jan 2008 15:14 Modified: 15 Jan 2008 16:09
Reporter: Adam Manley Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / ODBC Severity:S1 (Critical)
Version:5.1.1 OS:Microsoft Windows (XP sp2)
Assigned to: CPU Architecture:Any

[15 Jan 2008 15:14] Adam Manley
Description:
A call to SQLGetInfo(...) for SQL_SPECIAL_CHARACTERS causes an access violation in the MYODBC5.DLL

Environment:
- MS Windows XP sp2
- All ODBC Core compenents reported as version 3.525.1117.0 (via About tab of ODBC Data Source Administrator)
- MyOdbc 3.51.22 is also installed
- MySql Server version 5.0.45-community-nt

How to repeat:
  
  SQLRETURN ret;
  wxChar szVal[4500 + 1] = {0};
  SQLSMALLINT lenVal = 4500;
  SQLSMALLINT lenValOut;
  SQLUINTEGER iVal;

  ret = SQLGetInfo(m_hdbc, SQL_SPECIAL_CHARACTERS, szVal, lenVal, &lenValOut);
[15 Jan 2008 16:09] Jess Balint
This is a duplicate of bug#33130.