Bug #33839 Diagram scrollbars do not work when zoom < 100
Submitted: 12 Jan 2008 22:28 Modified: 28 Jan 2008 20:03
Reporter: Matthew Williams Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:5.0.11 OS:Microsoft Windows (XP SP2)
Assigned to: CPU Architecture:Any
Tags: diagram scroll zoom
Triage: D3 (Medium)

[12 Jan 2008 22:28] Matthew Williams
Description:
When you zoom out (magnification is less than 100%) in a diagram the scrollbars do not allow you to reach the edge of the diagram. I have seen this happen both vertically and horizontally although the example below is only horizontal.

How to repeat:
Create a new diagram.
Set the zoom to 70.
Drag the horizontal scrollbar all the way to the right.
Note in the Model Navigator that your view is not actually all the way to the right.

Suggested fix:
Correctly match the scrollbar size and position to the zoom level.
[13 Jan 2008 5:52] Valeriy Kravchuk
Thank you for a bug report.
[28 Jan 2008 20:03] Alfredo Kojima
This is a duplicate of bug #33076 which has been fixed recently.