Bug #33738 My MySQL Browser & Administrator do not use kerning when editing SPs&Functions
Submitted: 8 Jan 2008 10:45 Modified: 16 Feb 2009 11:25
Reporter: Leoncio Madruga Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Query Browser Severity:S2 (Serious)
Version:1.2.12 OS:Microsoft Windows (VISTA Home Basic)
Assigned to: Mike Lischke
Tags: edition, kerning, query, script
Triage: D4 (Minor)

[8 Jan 2008 10:45] Leoncio Madruga
Description:
My MySQL Browser & Administrator begun to ignore kerning when editing stored procedures, functions and querys.

I reinstalled twice the tools but no change happens in his behavior.

I cannot change this behavior on the tools/options of mysql tools, even if I select a type font with kerning data.

When this problem arose, others text editors (notepad, notepad++) also begun to ignore kerning during edition, but after choosing an type font with kerning data, the problem was resolved for notepad & notepad++, but not with mysql tools.

This begun when I did some changes (I don't know what) on my Vista Home Basic.

When the kerning is not used, all characters have the same length, and line space calculations goes wrong.

How to repeat:
I don't know. May be an option (i dont know either) in Windows Vista can cause this problem.

Suggested fix:
Always use kerning data when available on selected font
[9 Jan 2008 9:57] Miguel Solorzano
Thank you for the bug report.
[3 Mar 2008 13:09] Max Delbruck
My OS: Microsoft Windows (VISTA Home Premium).
Use Consolas font (width:8 size:9).
[16 Feb 2009 11:25] Mike Lischke
Leoncio, text where all letters have the same width use a socalled monospace font (e.g. Courier New is a monospace font). In general code editors prefer monospace fonts in order to allow proper alignment of text in text columns. You can select any font in QB but its code editors only work with monospace fonts properly. If you don't like a serif monospace font like Courier New then I recommend to look for Monospace821BT, which is a sans-serif monospace font with excellent look. I use it for every code editor I have (on Windows, OS X and Ubuntu).