Bug #33709 No error when importing sql script
Submitted: 6 Jan 2008 5:17 Modified: 8 Jan 2008 13:31
Reporter: Diego Medina Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S2 (Serious)
Version:5.0.11 OS:Microsoft Windows
Assigned to: CPU Architecture:Any
Triage: D3 (Medium)

[6 Jan 2008 5:17] Diego Medina
Description:
Import a sql script with 3 tables, where on table has some syntax error and the table will not be imported into Workbench but you will not get any error. It would be easy to notice the 3rd table missing but with 20+ tables, it would be pretty difficult.

How to repeat:
See Description

Suggested fix:
N/A
[6 Jan 2008 5:22] Diego Medina
right after posting the bug report I found a half way there kind of option
Going to the menu View->Advance->output window  will show you some messages related to the import process, but the last line will only tell you the number of errors/warnings, but there is no detail of those errors or warnings.
[7 Jan 2008 9:48] Miguel Solorzano
Thank you for the bug report. Could you please provide the sql script test
case. Thanks in advance.
[7 Jan 2008 15:58] Diego Medina
sql file for test case

Attachment: impact_system.sql (application/octet-stream, text), 4.06 KiB.

[7 Jan 2008 15:59] Diego Medina
look at line 25 of the previously submitted file, I have two closing parenthesis there.

From WB, the last line from the window output says:

10:55:46 | Finished parsing MySQL SQL script. Totally processed statements: successful (3), errors (1), warnings (2).
[8 Jan 2008 11:26] Miguel Solorzano
Thank you for the feedback.
[8 Jan 2008 13:31] Sergei Tkachenko
Duplicate of http://bugs.mysql.com/33681