Bug #33508 Cannot compile with nant
Submitted: 25 Dec 2007 13:09 Modified: 11 Jan 2008 6:03
Reporter: Vladimir Kamarzin Email Updates:
Status: Closed Impact on me:
Category:Connector / NET Severity:S2 (Serious)
Version:5.1.4 OS:Linux
Assigned to: CPU Architecture:Any

[25 Dec 2007 13:09] Vladimir Kamarzin
+ cd mysql-connector-net-5.1.4
+ nant -buildfile:Client.build mono-2.0
NAnt 0.86 (Build 0.86.2915.0; dev; 12/25/2007)
Copyright (C) 2001-2007 Gerry Shaw

Buildfile: file:///usr/src/RPM/BUILD/mysql-connector-net-5.1.4/Client.build
Target framework: Mono 2.0 Profile
Target(s) specified: mono-2.0



    [mkdir] Creating directory '/usr/src/RPM/BUILD/mysql-connector-net-5.1.4/Driver/bin/mono-2.0/release'.
   [resgen] Read in 71 resources from '/usr/src/RPM/BUILD/mysql-connector-net-5.1.4/Driver/Properties/Resources.resx'
   [resgen] Writing resource file...  Done.
      [csc] Compiling 88 files to '/usr/src/RPM/BUILD/mysql-connector-net-5.1.4/Driver/bin/mono-2.0/release/MySql.Data.dll'.
      [csc] /usr/src/RPM/BUILD/mysql-connector-net-5.1.4/Driver/Source/Resources.Designer.cs(25,20): error CS0101: The namespace `MySql.Data.MySqlClient' already contains a definition for `Resources'
      [csc] /usr/src/RPM/BUILD/mysql-connector-net-5.1.4/Driver/Properties/Resources.Designer.cs(24,20): (Location of the symbol related to previous error)
      [csc] Compilation failed: 1 error(s), 0 warnings

BUILD FAILED - 0 non-fatal error(s), 2 warning(s)

How to repeat:
Try to compile with latest nant
[9 Jan 2008 21:12] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

[9 Jan 2008 21:29] Reggie Burnett
Fixed in 5.1.5
[10 Jan 2008 5:57] Vladimir Kamarzin
Still cannot compile svn revision 1149 with same error. Compiler - nant-0.86 cvs 20071225
[10 Jan 2008 8:47] Tonci Grgin
Thanks Reggie.

Hi Vladimir, are you sure about "svn revision 1149"? I'm using dev SVN repo and just now it shows rev. 1148?
[10 Jan 2008 9:48] Vladimir Kamarzin
Yes i'm sure ;)

I see there "Revision 1149: /branches/5.1"
[10 Jan 2008 15:39] Reggie Burnett

Not sure what to tell you.  I did the changes with nant 0.85 but just downloaded 0.86 and tried with it.  It compiled up just fine.  Revision 1149 was in the 1.0 branch.  The latest revision in the 5.1 branch is 1148 and it seems to compile with nant just fine.
[10 Jan 2008 17:32] MC Brown
A note has been added to the 5.1.5 changelog: 

Connector/NET would fail to compile properly with nant.
[11 Jan 2008 6:03] Vladimir Kamarzin
It was my fail. I'm using SCM git http://git.or.cz/ and it was not remove files automatically when i merged svn-imported branch '5.1'.

It compiles fine now. Thanks!