Bug #33157 UI Executing proc steals focus
Submitted: 12 Dec 2007 3:21 Modified: 10 Feb 2009 22:25
Reporter: Jared S (Silver Quality Contributor) Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Query Browser Severity:S3 (Non-critical)
Version:1.2.12 OS:Microsoft Windows (Any)
Assigned to: Mike Lischke CPU Architecture:Any
Tags: focus, qc

[12 Dec 2007 3:21] Jared S
Description:
Hi,

When I execute proc, the text editor losses focus, which then prevents all subsequent CTR-ENTER key strokes to be ignored.

How to repeat:
DELIMITER $$

DROP PROCEDURE IF EXISTS `test`.`MyProc` $$
CREATE PROCEDURE `test`.`MyProc` ()
BEGIN
select 1;
END $$

DELIMITER ;

-- Try to run this query twice using CTR-ENTER
call MyProc

Suggested fix:
Return .focus to the text editor area of the query window after query is run.
[12 Dec 2007 4:13] Valeriy Kravchuk
Thank you for a bug report. Verified just as described.

You can use toolbar button to run procedure many times, so I'd say it is not a critical problem.
[15 Dec 2007 0:55] Jared S
Also the query editior should have focus on startup as well!
[10 Feb 2009 13:10] Mike Lischke
I cannot reproduce the mentioned behavior. Btw, the SQL is more than one command but in the query area you only execute one at a time per ctrl+enter. Still, when I tried focus remained in the editor and I could immediately re-execute the single command. Please try with a newer version.
[10 Feb 2009 22:25] Jared S
CTR-ENT sequence won't work in script tab, so this bug has to be closed.
http://bugs.mysql.com/bug.php?id=41910