Bug #33063 ndb related tests fail when building with gcc 4.2
Submitted: 7 Dec 2007 13:52 Modified: 12 Dec 2007 21:17
Reporter: Norbert Tretkowski Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Cluster: Cluster (NDB) storage engine Severity:S3 (Non-critical)
Version:5.0.51 OS:Linux (Debian 4.0)
Assigned to: Assigned Account CPU Architecture:Any

[7 Dec 2007 13:52] Norbert Tretkowski
Description:
All ndb related tests from the testsuite fail with "Error 1296 Got error 879 '879' from NDB" on i386 and x86_64 when built with gcc 4.2 (4.2.3 20071123 (prerelease)). It works when built with gcc 4.1 (4.1.2 20061115 (prerelease)).

Complete build log follows...

How to repeat:
Configure with --with-ndbcluster and build with gcc 4.2, then run the testsuite.
[7 Dec 2007 14:14] Norbert Tretkowski
build log

Attachment: buildd.log.gz (application/x-gzip, text), 111.43 KiB.

[12 Dec 2007 14:55] Hartmut Holzgraefe
I can't reproduce this on Debian testing with gcc 4.2.3,
the ndb tests are performing just fine
[12 Dec 2007 16:45] Norbert Tretkowski
I was unable to reproduce this bug with 5.0.52, but it affects 5.0.51.
[12 Dec 2007 17:04] Hartmut Holzgraefe
Tested with 5.0.51 source on amd64 using current Debian "lenny",
now trying with Debian "etch" and gcc-4.2.3 packages fetched
from "lenny" ...
[12 Dec 2007 17:49] Jonas Oreland
how about http://bugs.mysql.com/bug.php?id=31761
[12 Dec 2007 19:52] Norbert Tretkowski
Jonas, you're right, this is a duplicate. Sorry.
[12 Dec 2007 21:17] Hartmut Holzgraefe
Ok, i was using the BUILD/compile-amd64-debug-max which sets different compile options, with BUILD/compile-amd64-max i can verify the failure.