Bug #33015 CHECKSUM TABLE reporting different values on master and slave, but shouldn't
Submitted: 5 Dec 2007 19:36 Modified: 16 Dec 2007 10:54
Reporter: Bruce Bristol Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Replication Severity:S2 (Serious)
Version:5.0.22-log OS:Linux (Linux zpba37.corp.google.com 2.4.22-gg13smp #13 SMP Fri Apr 29 16:00:34 PDT 2005 i686 i686 i386 GNU/)
Assigned to:
Tags: checksum, master, slave

[5 Dec 2007 19:36] Bruce Bristol
Description:
I’ve received strange results using CHECKSUM TABLE on a static master and slave.

I found one table that had different checksums. I set out to find out the difference. I used mysqldump of the offending table on the master and copied it to and loaded it into the test database on the slave.

I did a query to find any differences and it came up empty.

I then ran CHECKSUM TABLE from within the MySQL client on both tables on the slave and the checksums were equal.

I did the same back on the master and it was still different.

So we have a case where MySQL is returning different checksums for the same table on the same version of MySQL.

How to repeat:
Explained in description

Suggested fix:
Not sure...
[6 Dec 2007 8:23] Shane Bester
Bruce, please check if those tables had FLOAT columns?
[6 Dec 2007 18:15] Bruce Bristol
No floats, but doubles and bigints.  Perhaps it's the doubles?
[16 Dec 2007 3:16] Bruce Bristol
Where do things stand now?  Has MySQL been able to reproduce the bug?

As it stands CHECKSUM TABLE is useless unless it works properly.

Thanks!

-Bruce
[16 Dec 2007 10:54] Sergei Golubchik
a duplicate of bug#30041