Bug #32938 PK on reverse engineered table
Submitted: 3 Dec 2007 18:14 Modified: 4 Dec 2007 7:37
Reporter: Sergey Romanov Email Updates:
Status: Not a Bug Impact on me:
Category:MySQL Workbench Severity:S1 (Critical)
Version:5.0.10 SE Beta OS:Windows (XP SP2)
Assigned to: CPU Architecture:Any
Tags: primary key

[3 Dec 2007 18:14] Sergey Romanov
Software do not create automatically and impossible to create manually PK on reverse engineered or already existed table.

How to repeat:
1. Go to "Edit table..."
2. Go to "Columns" tab
3. Create any column with AI
4. Go to "Indexes" tab
5. You can see that primary key is not created
6. Try to create primary key
7. This is impossible to select PRIMARY in dropdown

Suggested fix:
Software should create primary key automatically like for new tables and should be possible to create primary keys manually.
[3 Dec 2007 21:38] MySQL Verification Team
Thank you for the bug report.
[3 Dec 2007 22:40] Alfredo Kojima
To create a PK you have to double-click the column icon (the blue diamond) in the table editor, at left of the column name. It should become a yellow key icon, which indicates a PK.
[4 Dec 2007 7:37] Sergey Romanov
Yes, I know that necessary to change column icon to key. But I tried to make this some tens times without result. Today I tried to make this one more time and this work. Very strange. I have noticed, that a lot of bugs are not persistent and they disappear after workbench restart.