Bug #32729 ndb-connectors configure doesn't check for min. java version
Submitted: 26 Nov 2007 17:52 Modified: 19 Nov 2010 10:34
Reporter: Hartmut Holzgraefe Email Updates:
Status: Won't fix Impact on me:
Category:Connectors: NDB/Bindings Severity:S3 (Non-critical)
Version:ndb-connectors-, ndb-bindings-0.6.2 OS:Linux
Assigned to: CPU Architecture:Any

[26 Nov 2007 17:52] Hartmut Holzgraefe
Minimum requirement seems to be JDK 1.5 but the configure 
script doesn't check for this, reporting everything is fine
even with JDK 1.4 (which is what i have installed as i'm
still running OpenSuSE 10.0 here)

Later on the compilation fails badly as 1.5 specific things
as "@Deprecated" modifiers are used

How to repeat:
configure and make ndb-connectors on a system with 
a JDK older than 1.5

Suggested fix:
add java version sanity check to configure
[10 Apr 2008 23:34] Sveta Smirnova
Thank you for teh report.

Verified as described, although README contains a note about only JDK6 is supported