Bug #32547 Reverse Engineering Database Schema skipping selected tables
Submitted: 20 Nov 2007 20:13 Modified: 22 Nov 2007 4:41
Reporter: Fred Dinkler Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S2 (Serious)
Version:5.0.9 OS:Microsoft Windows (XP)
Assigned to: CPU Architecture:Any
Tags: reverse engineering, skipping tables

[20 Nov 2007 20:13] Fred Dinkler
Description:
When reverse engineering a database schema, the process skipped the last half of the list of selected tables when creating the diagram.

How to repeat:
Select Database / Reverse Engineer...
connect to a db, select a schema, select table objects to reengineer
Note the number of tables chosen to reverse engineer
Check "Autopopulate a diagram"

Compare the number of tables in the diagram with the number originaly selected

Suggested fix:
Reverse engineer all selected table objects
[20 Nov 2007 20:16] marc castrovinci
It's not skipping them. 
Look at this bug. http://bugs.mysql.com/bug.php?id=32539

Do you see the table names in the right hand side in the "Layers" list?
[20 Nov 2007 20:30] Fred Dinkler
You are correct - they are being skipped in that they aren't being placed on the diagram. They are being reverse engineered.
[22 Nov 2007 4:41] Valeriy Kravchuk
Duplicate of Bug #32539.