Bug #32299 Graphs cached across timezone change
Submitted: 12 Nov 2007 22:44 Modified: 4 Feb 2008 20:27
Reporter: Joshua Ganderson Email Updates:
Status: Duplicate Impact on me:
Category:MySQL Enterprise Monitor: Web Severity:S3 (Non-critical)
Version: OS:Any
Assigned to: Assigned Account CPU Architecture:Any

[12 Nov 2007 22:44] Joshua Ganderson
When you have a graph that displays times and you update your timezone, the graphs are not immediately updated to reflect the new timezone.

How to repeat:
View graphs on the monitor page.
Update your timezone.
Note that the graphs are still in old timezone.

Suggested fix:
Add user's current timezone to filename of cached graph. That graph won't be found if the user changes their timezone and will cause a new image to be generated.
[13 Nov 2007 18:29] Joshua Ganderson
patch sent
[13 Nov 2007 18:56] Sloan Childers
r8094 development-1.2.1
[14 Nov 2007 16:43] Sloan Childers
r8188 development-1.2.1 (fixing test cases broken by original patch)
[15 Nov 2007 0:39] Andrew Cwik
fixed in
[17 Nov 2007 19:04] Sloan Childers
Fixed in 1.3, reopening to fix in 2.0
[4 Feb 2008 20:27] Joshua Ganderson
dupe of 31680 which is in qa testing for 2.0?