Bug #32285 Select with ps-protocol: not formated output, float/double/real with zerofill
Submitted: 12 Nov 2007 15:37 Modified: 28 Feb 2008 17:29
Reporter: Horst Hunger Email Updates:
Status: Closed Impact on me:
None 
Category:Tests: Server Severity:S3 (Non-critical)
Version:5.1.23-beta OS:Linux (Suse 10.1)
Assigned to: Horst Hunger CPU Architecture:Any
Triage: D3 (Medium)

[12 Nov 2007 15:37] Horst Hunger
Description:
The test myisam_views.test failed with ps-protocol. The attached test reproduces the bug, which seems to be in mysqltest. the ouput without ps-protocol is like expected:
PREPARE stmt1 FROM 'select f1, f2, f3 FROM t1';
select f1, f2, f3 FROM t1;
f1      f2      f3
0000000000000003.14152  0000000000000003.14152  000003.14152
select f1, f2, f3 FROM t1;
f1      f2      f3
0000000000000003.14152  0000000000000003.14152  000003.14152
EXECUTE stmt1;
f1      f2      f3
0000000000000003.14152  0000000000000003.14152  000003.14152

The output with ps-protocol has not the expected format:

PREPARE stmt1 FROM 'select f1, f2, f3 FROM t1';
select f1, f2, f3 FROM t1;
f1      f2      f3
3.14152 3.14152 3.14152
select f1, f2, f3 FROM t1;
f1      f2      f3
3.14152 3.14152 3.14152
EXECUTE stmt1;
f1      f2      f3
0000000000000003.14152  0000000000000003.14152  000003.14152

See also bug#11589.

How to repeat:
execute attached program with mysql-test-run.pl with/without --ps-protocol.
[12 Nov 2007 22:27] Miguel Solorzano
Thank you for the bug report.