Bug #32142 node crashes if one tries to add data file while cluster is under load
Submitted: 6 Nov 2007 11:31 Modified: 6 Feb 2008 5:32
Reporter: Bogdan Kecman Email Updates:
Status: Verified Impact on me:
None 
Category:MySQL Cluster: Cluster (NDB) storage engine Severity:S3 (Non-critical)
Version:mysql-5.1 OS:Linux
Assigned to: Assigned Account CPU Architecture:Any
Tags: 5.1.21-beta, GCP
Triage: Triaged: D1 (Critical)

[6 Nov 2007 11:31] Bogdan Kecman
Description:
During load of a mysql dump into the cluster with disk based data the following error was encountered:
2007-11-06 12:01:09 [ndbd] INFO -- Node 2 killed this node because GCP stop was detected
2007-11-06 12:01:09 [ndbd] INFO -- NDBCNTR (Line: 235) 0x0000000a
2007-11-06 12:01:09 [ndbd] INFO -- Error handler shutting down system
2007-11-06 12:03:39 [ndbd] INFO -- Error handler shutdown completed - exiting
2007-11-06 12:03:39 [ndbd] ALERT -- Node 2: Forced node shutdown completed. Caused by error 2303: 'System error, node killed during node restart by other node(Internal error, programming error or missing error message, please report a bug). Temporary error, restart node'.

This happened when adding another datafile to the table space using the command:
mysql [sc] >alter tablespace ts_1 add datafile 'data_3.dat' initial_size 1024M engine=ndb;
ERROR 1530 (HY000): Failed to alter: CREATE DATAFILE

How to repeat:
Load data from mysql dump and while data is being loaded try to add new data file.

Suggested fix:
DDL (Data Definition Language) statements should only be performed in single user mode, with no DML (Data Modification Language) going on at the same time.
[6 Nov 2007 12:54] Tomas Ulin
please provide the logs from the cluster

BR,

Tomas
[15 Nov 2007 10:58] Johan Jerrang
Please see mysql support issue #20717.
[10 Dec 2010 1:28] Bogdan Kecman
I cannot reproduce this with 7.x any more, and I did managed to reproduce it with 6.3, so I believe this one is fixed. Not sure if it was Pekka's or Jonas's patch that solved it but looks like it is solved.