Bug #32104 Cmd+A does not work in SQL query editor
Submitted: 5 Nov 2007 12:42 Modified: 13 Nov 2007 9:06
Reporter: Matt Mower Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Query Browser Severity:S3 (Non-critical)
Version:1.2.12 OS:Mac OS X
Assigned to: CPU Architecture:Any

[5 Nov 2007 12:42] Matt Mower
Description:
When editing a SQL query the standard MacOSX keyboard shortcut for "Select All Text" in a text editing widget, Cmd+A, does not work and instead you get a system beep.

I'm not aware of any haxies or system modifying software on my computer that might be causing this and I can't find any other application where I can duplicate this loss of functionality.

Although you can select the text either with the mouse or using arrow keys it's quite an inconvenience when a standard MacOSX shortcut doesn't work.

How to repeat:
Open MySQL query browser, select a table, write a SQL query, hit Cmd+A.

Suggested fix:
Make Cmd+A work as it does in every other MacOSX text editing widget, i.e. it should not beep but select all text in the widget.
[13 Nov 2007 8:50] Sveta Smirnova
Thank you for taking the time to write to us, but this is not a bug. Please double-check the documentation available at http://dev.mysql.com/doc/ and the instructions on
how to report a bug at http://bugs.mysql.com/how-to-report.php

Shortcut for "Select Query Area" is Cmd + L, not Cmd + A
[13 Nov 2007 9:06] Matt Mower
Funny but if Query Browser followed the MacOSX conventions I wouldn't have had to read the documentation because it would work like *every other MacOSX application*.

Seriously, why on earth would you invent a new shortcut for this?

And even if, for some legacy reason, you had a reason to want Cmd+L to select the query please can you tell me why you would disable the shortcut that any user of MacOSX would automatically expect to work?

This seems to be deliberately perverse to me.
[21 Jul 2009 7:23] Seth Hill
This really needs to be re-opened. This is a complete UI bug (I've just spent the last 15 minutes listening to my Mac beep at me when I press Cmd-A, wondering what the problem is). 

Every other application running on Mac OS for the last 24 years has Cmd-A mapped to "Select All". 

For that matter, on the Windows version of query browser, Ctrl-A gives me Select All.