Bug #31676 init script missing from service manager
Submitted: 17 Oct 2007 20:59 Modified: 13 Nov 2008 10:29
Reporter: Monty Taylor Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Enterprise Monitor: Installing Severity:S3 (Non-critical)
Version:1.2 OS:Any
Assigned to: BitRock Merlin
Triage: D3 (Medium) / R3 (Medium) / E3 (Medium)

[17 Oct 2007 20:59] Monty Taylor
Description:
There is no init script installed for the MySQL Network Monitoring Service Manager. 

How to repeat:
Install the latest 1.2. Look for an init script.

Suggested fix:
Install an init script
[17 Oct 2007 21:10] Keith Russell
Currently nothing is installed outside of the directory tree created by the installer.  Adding this will require the installer to verify that the user running the installer to have the appropriate privileges to write to directories outside of the tree it creates.
[17 Oct 2007 21:13] Monty Taylor
The agent installs an init script - can the process there be duplicated?
[16 Nov 2007 20:47] Bill Weber
changing status to Verified for bug-council queries
[8 Jan 2008 15:27] Valerii Kravchuk
Bug #33652 was marked as a duplicate of this one.
[29 Jan 2008 3:53] Andy Bang
1) Please use the native service installer to configure the Service Manager to auto-start on reboot on the following platforms:

     AIX 5.2
     FreeBSD 6
     HP-UX
     Linux - Debian distros
     Linux - Red Hat distros
     Mac OS X
     Solaris 8, 9, & 10
     Windows

Please let us know if it would be difficult or impossible to support this on some of these platforms.

2) If the user has NOT installed as root, display the following text at the end of installation or in the Configuration Report:

"You have not installed the MySQL Enterprise Monitor as the root user.  Therefore it could not be configured to auto-start on reboot.  See the Installation section of the MySQL Enterprise Monitor documentation for instructions on how to do this manually."

3) Peter, After BitRock gets this working, please revisit the related sections in the documentation.  I think an extra sentence or two about copying ${installdir}/etc/init.d/mysql-enterprise-monitor to /etc/init.d/mysql-enterprise-monitor, and then running chkconfig, update-rc.d, etc., is warranted.
[4 Feb 2008 20:15] Andy Bang
It's too late in the 1.3 release cycle for this, so we'll get this done in the 2.0 release.
[14 Oct 2008 16:08] Keith Russell
Bitrock Support,

The 'mysqlmonitorctl.sh' file has been renamed to 'mysql-monitor-server'.  Comments have been added to the top of the script. Please use this as the 'init.d' script.  A copy has been placed in the ftp root directory.
[16 Oct 2008 18:13] BitRock Merlin
Patch sent to Keith
[17 Oct 2008 20:57] Keith Russell
Patch applied in version => 2.0.0.7078.
[7 Nov 2008 23:16] Marcos Palacios
Tested OK with build 2.0.0.7092 on Linux - Fedora distribution.
[7 Nov 2008 23:21] Marcos Palacios
The test above involved rebooting the box (after having the service manager running on it) and verifying that the service manager auto started after the reboot, in addition to checking that the startup script was put in /etc/init.d.
[10 Nov 2008 21:44] Marcos Palacios
Resetting to 'Verified' due to the 2nd item requested in the comment dated [29 Jan 4:53] NOT being implemented: I installed build 2.0.0.7092 as a non-root user (on Open Solaris 2008.05) but the installer did not display the requested text.
[11 Nov 2008 11:12] BitRock Merlin
Patch sent to Keith.
[12 Nov 2008 15:40] Keith Russell
Patch applied in build versions => 2.0.0.7094.
[12 Nov 2008 21:23] Marcos Palacios
Verified fixed in build 2.0.0.7094.
[13 Nov 2008 10:29] Tony Bedford
An entry was added to the 2.0 changelog:

No init script was installed for the MySQL Network Monitoring Service Manager, and so it did not restart automatically on reboot.