Bug #31660 mysql stops when starting with replication options+missing mysql table
Submitted: 17 Oct 2007 9:08 Modified: 29 Oct 2007 21:58
Reporter: Peter van Beugen Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Replication Severity:S2 (Serious)
Version:5.1.22 OS:Microsoft Windows (2003 SP 2)
Assigned to: CPU Architecture:Any

[17 Oct 2007 9:08] Peter van Beugen
Description:
I have set up a 5.1.22 windows server as a replication slave for a 5.0.27 master (linux). I tried both 5.1.22 linux as well as windows. Running the Windows MySQL 5.1.22 server as is, is no problem, but when setting up as a slave the mysql service stops with these error messages:

071012 15:39:01 [ERROR] Can't open and lock privilege tables: Table 'mysql.servers' doesn't exist

digging in I found that the mysql.servers table is complete missing in the Windows mysql database configuration. I copied it from a Linux installation and after that this error message disappear.

but setting up replication in the my.ini and restarting the service gives these errors (watch the Event Scheduler errors!) :

071017 10:49:02 [Note] Plugin 'InnoDB' disabled by command line option
071017 10:49:03 [ERROR] Event Scheduler: Failed to open table mysql.event
071017 10:49:03 [ERROR] Event Scheduler: Error while loading from disk.
071017 10:49:03 [Note] Event Scheduler: Purging the queue. 0 events
071017 10:49:03 [ERROR] Aborting

071017 10:49:03 [Note] C:\Program Files\MySQL\MySQL Server 5.1\bin\mysqld: Shutdown complete

removing the slave setup in my.ini en restarting the service:
071017 11:04:12 [Note] Plugin 'InnoDB' disabled by command line option
071017 11:04:12 [Warning] Neither --relay-log nor --relay-log-index were used; so replication may break when this MySQL server acts as a slave and has his hostname changed!! Please use '--relay-log=D:\mysqldata\ARCHIE_SERV-relay-bin' to avoid this problem.
071017 11:04:12 [Note] Event Scheduler: Loaded 0 events
071017 11:04:12 [Note] C:\Program Files\MySQL\MySQL Server 5.1\bin\mysqld: ready for connections.
Version: '5.1.22-rc-community'  socket: ''  port: 3306  MySQL Community Server (GPL)

the Event Scheduler errors dissapear and the mysql service starts ok.

How to repeat:
install 5.1.22 windows (32) and set up as a replication server
[24 Oct 2007 12:44] MySQL Verification Team
Thank you for the bug report. Could you please provide the my.ini/my.cnf
for both servers: master and slave. Thanks in advance.
[26 Oct 2007 13:49] Peter van Beugen
added the requested files
[29 Oct 2007 20:42] Sveta Smirnova
Thank you for the report.

This looks like duplicate of bug #31111. Please try to keep replication options and remove read-only flag and inform us if slave/replication starts correctly.
[29 Oct 2007 21:46] Peter van Beugen
restarted replication without the read-only flag and replication did start correctly!!

replication is running now
[29 Oct 2007 21:58] Sveta Smirnova
Thank you for the feedback.

Marked as duplicate of bug #31111 according to the last comment.