Bug #31570 wrong translation in the german documentation
Submitted: 12 Oct 2007 17:31 Modified: 15 Oct 2007 15:19
Reporter: Hanno Wagner Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server: Documentation Severity:S3 (Non-critical)
Version:5.1 (and earlier?) OS:Any (atomisch is wrong)
Assigned to: Stefan Hinz CPU Architecture:Any
Tags: translation german
Triage: D4 (Minor)

[12 Oct 2007 17:31] Hanno Wagner
Description:
within http://dev.mysql.com/doc/refman/5.1/de/lock-tables.html  there is a sentence "Normalerweise müssen Sie Tabellen nicht sperren, weil alle UPDATE-Anweisungen für sich atomisch sind". I think the correct word is "atomar", not "atomisch"

How to repeat:
just read http://dev.mysql.com/doc/refman/5.1/de/lock-tables.html ;)

Suggested fix:
replace "atomisch" with "atomar" in the complete documentation if it is there multiple times.
[15 Oct 2007 15:19] Stefan Hinz
Thank you for taking the time to write to us, but this is not a bug. The term "atomisch" might have been new in 2001 when I did the first translation of the MySQL Manual (maybe I invented it? ;-)) but in the meantime it's been established in IT literature (while maybe still not as common as "atomar").
[9 Mar 2008 7:53] Geri Broser
I can assure you I read "atomisch", and used it in DB-Trainings I gave, already before 1999. (Sorry, to take the glory away from you with this ;-)

"Atomar", as I always understood it, is used in the sense of 'nuclear', e.g. 'the nuclear threat', "die atomare Gefahr".