Bug #31370 mysqld --help --verbose doesn't work if /etc/my.cnf prevents server startup
Submitted: 3 Oct 2007 13:51 Modified: 3 Oct 2007 14:34
Reporter: Sergey Petrunya Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: General Severity:S3 (Non-critical)
Version:5.2-bk OS:Any
Assigned to: CPU Architecture:Any

[3 Oct 2007 13:51] Sergey Petrunya
Description:
As a non-root user on some machine I've ended up in this situation:

There is /etc/my.cnf file which contains an error which prevents mysqld from starting. I chose to specify correct mysqld arguments myself, including some argument that would cause it to ignore /etc/my.cnf. I type

  mysqld --help

to find out what is the option to ignore /etc/my.cnf, but this still causes mysqld  to try processing /etc/my.cnf and fail with an error without printing the help text.

How to repeat:
see above

Suggested fix:
make option processing work in such a way that "mysqld --help" and "mysqld --help --verbose" print help text irrespectively of the contents of the /etc/my.cnf file.
[3 Oct 2007 14:34] Miguel Solorzano
Thank you for the bug report. Duplicate of bug: http://bugs.mysql.com/bug.php?id=30970