Bug #31213 Agent update installer places the backup in an unspecified directory
Submitted: 26 Sep 2007 18:46 Modified: 6 Nov 2007 16:01
Reporter: Keith Russell Email Updates:
Status: Can't repeat Impact on me:
Category:MySQL Enterprise Monitor: Installing Severity:S3 (Non-critical)
Version: + OS:Any
Assigned to: BitRock Merlin CPU Architecture:Any

[26 Sep 2007 18:46] Keith Russell
When updating the agent from 1.2.0.xxxx from the older /opt/mysql/network/monitoring' directory, and choosing to update in the same directory, and create a backup before installing, the backup it creates is placed in /opt/mysql/enterprise

How to repeat:
Update an agent installation to version are higher and request that the current installation be backed up. 

Suggested fix:
Place the backup in the current installed directory instead of creating a new directory path.
[27 Sep 2007 8:36] BitRock Merlin
We have been unable to reproduce this on our side. We tried a 1.2.xxx -> 1.2.yyy update and a -> 1.2.yyy update, both of them on Linux, running as root (as we think is the environment where the bug was detected).

The previous installdir was placed at:


And the backup dir was successfully placed at:

[27 Sep 2007 9:25] BitRock Merlin
Also, I forgot to mention that the case description has wrong paths:

/opt/mysql/network/monitoring (which is the server path, not the agent one)

/opt/mysql/enterprise (should be /opt/mysql/enteprise/agent/patchbackup?)

But as the case is related to the agent, I just used the regular old paths (/opt/mysql/network/agent and /opt/mysql/network/agent/patchbackup) and, as mentioned earlier, the update worked fine.
[28 Sep 2007 21:55] Keith Russell
Additional information. 
Here were the options used when installing that produced the backup in the /opt/mysql/enterprise/agent directory.

./mysqlserviceagent- --mode unattended --installdir /opt/mysql/network/agent

So it appears that if a '--backupdir' is not specified it creates a new directory for it instead of placing it in the 'installdir'.
[6 Nov 2007 12:40] BitRock Merlin
We have tried to reproduce this case using the following directives:
 - Linux x86 32 bits OS
 - Root user
 - Command line invocation: ./mysqlserviceagent-1.2.0-linux-update-installer.bin --mode unattended --installdir /opt/mysql/network/agent

We have tried different scenarios in order to perform the update:
 1- One agent installation present in /opt/mysql/network/agent
 2- One agent installation present in /opt/mysql/enterprise/agent (here we used --installdir /opt/mysql/enterprise/agent, of course).
 3- Two agent installations, one in /opt/mysql/network/agent, the other one in /opt/mysql/enterprise/agent, updating /opt/mysql/network/agent.

In all three cases the update finished successfully, and the patchbackup/ was correctly created under the previous installation path (i.e., /opt/mysql/network/agent/patchbackup for scenarios 1 and 3, /opt/mysql/enterprise/agent/patchbackup for scenario 2).
[6 Nov 2007 16:01] Keith Russell
Moving to status "Can't repeat".