Bug #31049 Unexpected error with CAST
Submitted: 16 Sep 2007 19:47 Modified: 3 Jan 2008 5:11
Reporter: Tonci Grgin Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / ODBC Severity:S2 (Serious)
Version:5.1Alpha OS:Microsoft Windows (XPPro SP2)
Assigned to: CPU Architecture:Any
Tags: ADO, cast, date, ODBC

[16 Sep 2007 19:47] Tonci Grgin
Description:
Working on Bug#28113 I've found this error:
Error : Unspecified error
Code  : 80004005
Source: Provider
Line 57, Char 5 (.Open(strSQL))

How to repeat:
Test case attached to Bug#28113. No-ADO (C++) test case works as expected.

Suggested fix:
-
[8 Oct 2007 11:20] Susanne Ebrecht
Hi Tonci,

thanks for writing a bug report.

Regards,

Susanne
[9 Oct 2007 17:35] Jess Balint
Works fine on the latest 5.1 (rev 814). I used ADODB.CommandTypeEnum.adCmdText in the Options of rs.Open().

Tonci - Can verify this is still an issue for you?
[17 Oct 2007 9:25] Tonci Grgin
Still failing with latest versions for me. Tests done in wscript host (failing with error reported) and odbct32w (passing) against latest build available.
Logs attached.
[17 Oct 2007 9:28] Tonci Grgin
DM traces

Attachment: both-logs.zip (application/zip, text), 4.54 KiB.

[3 Jan 2008 5:11] Jess Balint
Duplicate of bug#10128
SQLNativeSql issue. will be fixed in Connector/ODBC 5.1.2 release