Bug #30984 SQL Statements longer than 128k cause a GPF
Submitted: 12 Sep 2007 15:55 Modified: 13 Sep 2007 7:40
Reporter: vha x Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / ODBC Severity:S3 (Non-critical)
Version:5.1.0 alpha OS:Microsoft Windows
Assigned to: CPU Architecture:Any

[12 Sep 2007 15:55] vha x
Description:
Using the following sql statement:
 
 INSERT INTO T (Col_1) VALUES (0xAABBCC...)
 
where Col_1 is of type LONGBLOB.
 
When using an SQL Statement longer that 127996 bytes, the statement
fails with a syntax error at offset 64k, but the next "SQLFreeStmt(hStmt, SQL_DROP) statement causes a GPF

How to repeat:
Using the following sql statement:
 
 INSERT INTO T (Col_1) VALUES (0xAABBCC...)
 
where Col_1 is of type LONGBLOB and the total SQL statement exceeds 127996 bytes.
[13 Sep 2007 7:40] Jess Balint
This is a duplicate of bug#30983.