Bug #30952 changing value of table_cache
Submitted: 11 Sep 2007 11:53 Modified: 11 Sep 2007 13:22
Reporter: Sabyasachi Ruj Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server Severity:S3 (Non-critical)
Version:5.0.45-community-nt OS:Microsoft Windows (XP)
Assigned to: CPU Architecture:Any
Tags: show variables, table_cache

[11 Sep 2007 11:53] Sabyasachi Ruj
Description:
If I am changing the value of table cache by speicifying the 
value '4000' in mysql adminstrator (v 1.2.12), it takes 969 (Not 4000).

The following query shows 969.

show global variables like'%table_cache%';

I do not think 969 is the default maximum value.

But If I am changing through the following SQL command:-
set global table_cache=4000;

Then it is correct and changes to 4000.

How to repeat:
Change the value of "Table Cache" in "Various" section of "Advanced" tab of "Startup Variables" to 4000.

Restart MySQL server, I can see the values it has taken is 969 by executing the following query:-

 show global variables like'table_cache';

But execute the query:-
 set global table_cache=4000;

And it will be set to 4000;
[11 Sep 2007 12:50] MySQL Verification Team
Thank you for the bug report. This an expected behavior when the server is
started:

c:\dev\5.0>bin\mysqld --standalone --console --table_cache=4000
070911  9:46:42 [Warning] Changed limits: max_open_files: 2048  max_connections: 100  table_cache: 969
070911  9:46:43  InnoDB: Started; log sequence number 0 43665
070911  9:46:44 [Note] bin\mysqld: ready for connections.
Version: '5.0.50-nt'  socket: ''  port: 3306  Source distribution

The issue is that currently the Windows server has a limitation of maximum
open files of 2048 and then a table cache of 4000 is so big.
[11 Sep 2007 13:09] Sabyasachi Ruj
Understand.
But why the number '969' everytime?
[11 Sep 2007 13:22] Sabyasachi Ruj
OK...

After searching more on this I got:-
http://bugs.mysql.com/bug.php?id=11269