Bug #30903 New ndb_size.pl options should be renamed
Submitted: 7 Sep 2007 15:42 Modified: 8 Sep 2007 12:30
Reporter: Jon Stephens Email Updates:
Status: Verified Impact on me:
Category:MySQL Cluster: Cluster (NDB) storage engine Severity:S4 (Feature request)
Version:mysql-5.1 OS:Any
Assigned to: CPU Architecture:Any
Tags: ndb, ndb_size.pl, program options

[7 Sep 2007 15:42] Jon Stephens
Many of the ndb_size.pl options changed or added in Bug #28683 could be better named to make them more intuitive and consisted with other MySQL programs.

How to repeat:
ndb_size.pl --help

Suggested fix:
--excludedbs -> --exclude-databases
--excludetables -> --exclude-tables
--loadqueries -> --load-queries-from or --load-queries-from-file
--savequeries -> --save-queries or --save-queries-to-file
[8 Sep 2007 12:30] Valeriy Kravchuk
Thank you for a reasonable feature request.