Bug #30799 Segfault after login
Submitted: 4 Sep 2007 16:07 Modified: 22 Dec 2007 17:58
Reporter: Nick Nott Email Updates:
Status: No Feedback Impact on me:
Category:Eventum Severity:S1 (Critical)
Version:2.0.1 OS:Linux (Suse 10.1)
Assigned to: CPU Architecture:Any

[4 Sep 2007 16:07] Nick Nott
I've installed the software, configured, etc but when logging in, it gives me a blank page to download (view.php) and further inspecting the issue I found out that httpd child is segfaulting:
Sep  4 17:47:47 scoop kernel: httpd2-prefork[16943]: segfault at 00007fffaf9c6ff8 rip 00002aabfd55c78b rsp 00007fffaf9c7048 error 6

I meet (hopefully) all software requirements, here is some info:

# php5 -i|grep configure
Configure Command =>  '../configure' '--prefix=/usr' '--datadir=/usr/share/php5' '--mandir=/usr/share/man' '--bindir=/usr/bin' '--with-libdir=lib64' '--includedir=/usr/include' '--sysconfdir=/etc/php5/cli' '--with-config-file-path=/etc/php5/cli' '--with-config-file-scan-dir=/etc/php5/conf.d' '--with-exec-dir=/usr/lib64/php5/bin' '--enable-magic-quotes' '--enable-libxml' '--enable-session' '--with-mm' '--with-pcre-regex' '--enable-xml' '--enable-simplexml' '--enable-spl' '--enable-safe-mode' '--enable-sigchild' '--disable-debug' '--enable-memory-limit' '--enable-inline-optimization' '--enable-zend-multibyte' '--disable-rpath' '--enable-cli' '--with-pear=/usr/share/php5/PEAR' '--enable-bcmath=shared' '--enable-calendar=shared' '--enable-ctype=shared' '--enable-dbase=shared' '--enable-dom=shared' '--enable-exif=shared' '--enable-filepro=shared' '--enable-ftp=shared' '--enable-mbstring=shared' '--enable-mbregex' '--enable-pcntl=shared' '--enable-posix=shared' '--enable-shmop=shared' '--enable-ucd-snmp-hack' '--enable-soap=shared' '--enable-sockets=shared' '--enable-sysvmsg=shared' '--enable-sysvsem=shared' '--enable-sysvshm=shared' '--enable-tokenizer=shared' '--enable-wddx=shared' '--with-zlib=shared' '--with-bz2=shared' '--with-curl=shared' '--with-gd=shared' '--enable-gd-jis-conv' '--enable-gd-native-ttf' '--with-xpm-dir=/usr/X11R6' '--with-freetype-dir=/usr' '--with-ttf' '--with-png-dir=/usr' '--with-jpeg-dir=/usr' '--with-zlib-dir=/usr' '--with-gettext=shared' '--with-gmp=shared' '--with-iconv=shared' '--with-imap=shared' '--with-kerberos' '--with-imap-ssl' '--with-ldap=shared' '--with-ldap-sasl=/usr' '--with-mcrypt=shared' '--with-mhash=shared' '--with-mysql=shared,/usr' '--with-mysql-sock=/var/lib/mysql/mysql.sock' '--with-mysqli=shared' '--with-ncurses=shared' '--with-unixODBC=shared,/usr' '--with-openssl=shared' '--with-pgsql=shared' '--with-pspell=shared' '--with-snmp=shared' '--with-xmlrpc=shared' '--enable-xmlreader=shared' '--enable-xmlwriter=shared' '--with-xsl=shared' '--with-tidy=shared,/usr' '--enable-dba=shared' '--with-db4=/usr' '--without-gdbm' '--with-cdb' '--with-inifile' '--with-flatfile' '--enable-pdo=shared' '--with-pdo_sqlite=shared' '--with-pdo-mysql=shared,/usr' '--with-pdo-pgsql=shared,/usr' '--with-sqlite=shared' '--enable-sqlite-utf8' '--disable-cgi'

# mysql -V
mysql  Ver 14.12 Distrib 5.0.18, for suse-linux (x86_64) using readline 5.1

# php5 -v
PHP 5.1.2 (cli) (built: May  2 2006 10:19:57)
Copyright (c) 1997-2006 The PHP Group
Zend Engine v2.1.0, Copyright (c) 1998-2006 Zend Technologies

# uname -ar
Linux scoop #1 SMP Wed May 3 04:53:23 UTC 2006 x86_64 x86_64 x86_64 GNU/Linux

First I thought the issue was with apache and some mime types (view.php being downloaded) but after that segfault it's clear that's not the case. I wanted to give it a try using gdb but my knowledge with it is limited and I'm not aware how to trace that single child process that segfaults. I'm guessing the issue is somewhere within system or how Eventum calls stuff after login is processed.

Running files manually from CLI worked fine, however I kept getting login page so couldn't actually test why view.php fails. No other errors reported except that segfault. (E_ALL enabled)

If I change URL to http://URL/eventum/view.php after I get that page to download, I can view stuff:

 Error: The issue # could not be found. 

 Go Back  

but as soon as I try and view a specific issue #, I get segfault and page to download.

How to repeat:
Probably matching exact PHP version on a x86_64 would be enough to replicate the issue.
[11 Sep 2007 13:35] Nick Nott
Tried upgrading PHP to 5.2.4, no luck. The only errors I get are in /var/log/messages and apache spits:
[Tue Sep 11 15:26:07 2007] [notice] child pid 31044 exit signal Segmentation fault (11)
[Tue Sep 11 15:29:45 2007] [notice] child pid 31474 exit signal Segmentation fault (11)

not sure where to dig further, any help finding the cause of this is appreciated :)

P.S running on apache 2.2.0
[22 Nov 2007 17:58] Valeriy Kravchuk
Thank you for a problem report. Please, try to repeat with a newer version, 2.1, and inform about the results.
[23 Dec 2007 0:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[31 Jan 2008 11:23] Tomas Vaidotas
Same problem with OpenSuse 10.2 with Eventum 2.1 and 2.1.1 versions.
after input of new issue, or clicking on issue number there is no information in browser window. 
Apache log shows segmentation fault (11)