Bug #30729 Add COMMENT attribute to CREATE VIEW
Submitted: 30 Aug 2007 18:27 Modified: 30 Apr 2009 5:42
Reporter: Oliver Smith Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Views Severity:S4 (Feature request)
Version:5.0+ OS:Any
Assigned to: CPU Architecture:Any
Tags: views comments
Triage: D5 (Feature request)

[30 Aug 2007 18:27] Oliver Smith
Description:
Views are one of the few MySQL entities that does not allow for a COMMENT attribute in the CREATE statement preventing inline documentation.

How to repeat:
CREATE VIEW v1 COMMENT "Not here" AS SELECT 1 FROM DUAL ;

Suggested fix:
Allow
CREATE VIEW v1 COMMENT "Allowed here" AS SELECT 1 FROM DUAL ;
[31 Aug 2007 12:27] Valeriy Kravchuk
Thank you for a reasonable feature request.
[7 Sep 2007 6:19] Valeriy Kravchuk
Duplicate of bug #15344.
[29 Apr 2009 18:26] John Bercik
Comments should support the syntax here:
 http://dev.mysql.com/doc/refman/5.0/en/comments.html
[30 Apr 2009 5:42] Oliver Smith
That's a different kind of comment, John :)