Bug #30161 Perl API - No "configure" with DBD-mysql-4.005
Submitted: 31 Jul 2007 22:09 Modified: 1 Aug 2007 19:34
Reporter: Daniel Barker Email Updates:
Status: Not a Bug Impact on me:
None 
Category:Connectors: DBD::mysql ( Perl ) Severity:S2 (Serious)
Version:14.12 Distrib 5.0.45 OS:Mac OS X (Intel)
Assigned to: CPU Architecture:Any

[31 Jul 2007 22:09] Daniel Barker
Description:
Dear Sir or Madam,

There seems to be no "configure" script with DBD::mysql. Also there is no obvious option to "perl Makefile.PL" that would achieve the same effect. This makes it unclear how to install the software in a non-default location.

How to repeat:
tar xfv DBD-mysql-4.005.tar

Suggested fix:
When I have got tests to work (see my other bug reported today), I may try omitting the "make install" step, and setting PERL5LIB appropriately. Do you anticipate problems with this?
[1 Aug 2007 7:22] Sveta Smirnova
Thank you for taking the time to write to us, but this is not a bug. Please double-check the documentation available at http://dev.mysql.com/doc/ and the instructions on
how to report a bug at http://bugs.mysql.com/how-to-report.php

Read at http://www.cpan.org/ how to install CPAN module. Alternatively you can run `perl Makefile.PL --help` to see option list.
[1 Aug 2007 11:10] Daniel Barker
Dear Sveta Smirnova,

Thank you for your advice. However I do believe this may be a bug.

For installation of DBD::mysql, neither the instructions on the MySQL Web site, nor those on CPAN provide information on how to install the DBD::mysql library in a non-default location. (N.B. I mean the location of the DBD::mysql Perl library. My installation of MySQL itself is in the default location. But I wish to keep Perl libraries in my home directory.)

Note, there is some information given on "configure" for different purposes (e.g. in documentation sections MULTITHREADING and INSTALLATION on CPAN) and I would have assumed a "--prefix" option would achieve my aim. However, there is actually no "configure" in the DBD::mysql distribution.

"perl Makefile.PL --help" provides no advice on how to put the Perl library in a non-default location. No option is documented as relating to the final destination of the Perl library.

As a work-around, would it be acceptable for me to set PERL5LIB to "point to" the location of mysql.pm, without "make install"? I mean, if I "make" then "make test" in ~/DBD-mysql-4.005/, could I simply add ~/DBD-mysql-4.005/lib to my PERL5LIB envionment variable, without actually doing any "make install"?

Thank you again for advice.

Best regards,

Daniel
[1 Aug 2007 19:34] Sveta Smirnova
Thank you for the feedback.

This behaviour is documented for every Perl module. You can find necessary information in man perlmodinstall