You have been subscribed for email updates to this bug report.
Bug #30055 mysql-query-browser is freezing every way i try to pick, or click, a scheme
Submitted: 25 Jul 2007 21:16 Modified: 14 Jan 2009 13:20
Reporter: Kaity G. B. Email Updates:
Status: Won't fix Impact on me:
None 
Category:MySQL Query Browser Severity:S1 (Critical)
Version:1.2 OS:Linux
Assigned to: CPU Architecture:Any
Tags: change, changing, clicking, crashes, database, default scheme, freezes, freezing, mysql-query-browser, picking

[25 Jul 2007 21:16] Kaity G. B.
Description:
mysql-query-browser is freezing,

whether i pick a 'default scheme' when logging in, clicking on any database in the right hand view, or clicking on any database from the lil pop-up window after trying select 'default scheme' through the menus.  the status bar says 'changing default scheme too' and it dies there.

this happens when i try to use either opensuse's, my distro's, mysql(server, gui-tools, &mysql-query-browser) packages or those downloaded directly from mysql.  i've tried downloading your opensuse rpms, generic rpms, and even your generic tarballs.

i'm using the current 1.2 version in every case.  as long as i don't click anywhere in the database view things appear to `work'.  meaning i can only run queries.

help?!?, please.

How to repeat:
if i enter a 'default scheme' on mysql-query-browser's connection screen, the connection screen goes away with mysql-query-browser-bin becoming zombied.  if i connect without one and than simply click on any available database.  the database icon is replace with a red circle with a red x through and the process zombies and i have to kill it.

Suggested fix:
?!? huh, i dunno.  i'm totally confuzzled, all dependencies are fine, ldd looks okay, i've tried everything &then some.  please help, i really love mysql-query-browser.
[26 Jul 2007 7:17] Kaity G. B.
**update**

just to let whoever gets this.  i've just finished building both your suse 10 and general source packages.  they built fine with an occasional warning from mysql-query-browser's own code about a deprecated conversion of a string constant to a character pointer but nothing more.  they both resulted in the same results as i explained above.

so now i'm in tears and i have no idea what else to try.  please any one?  any suggestions?  even another mysql gui that will help me.  i'm working on an extremely important, to me, project and being disabled and having only one functional hand to work with coding takes all the time and strength i have, i simply can't work with just typing in mysql's shell.  four years ago maybe but not now.  i'm sorry i know this isn't a 'standard' bug report update; but i'm really desperate and i've done everything i can.

so even if you're not on the dev. team or quadruply if you are absolutely anything that can help me will be so appreciated i can't even tell you.
[27 Jul 2007 3:00] MySQL Verification Team
Query Browser on Suse 10.2 X64

Attachment: QB-on-Suse-X64.png (image/png, text), 208.15 KiB.

[27 Jul 2007 3:04] MySQL Verification Team
Thank you for the bug report. Could you please download the package:
Generic x86 Linux TAR (bundled dependencies) and try. I attached
a screenshot with QB on Suse 10.2. Thanks in advance.
[27 Jul 2007 4:02] Kaity G. B.
i have tried that package,

its the one i'm referring to in my initial bug report when i say: "i've tried downloading your opensuse rpms, generic rpms, and even your generic tarballs."

and i've got the same window in your screen shot.  i'll attached two screen shots, one before trying to select a scheme and than one of the 'red crossed-circle off death' that i'm getting now.

it has been working, i've built this entire database using it and many others.  this is just my project of focus at the moment.  but i have no idea why its stopped working, what i may have had update maybe, but yeah i've tried both sets of your rpms.
[27 Jul 2007 4:10] Kaity G. B.
mysql-query-browser-bin with a running query, but no default scheme.

Attachment: working-query-browser.png (image/png, text), 79.25 KiB.

[27 Jul 2007 4:16] Kaity G. B.
mysql-query-browser-bin freezing when i select 'default scheme'

Attachment: dead-mysql-query-browser.png (image/png, text), 79.51 KiB.

[27 Jul 2007 21:03] MySQL Verification Team
Thank you for the feedback. Still I am not able to repeat, could you please
provide a dump file of your DB which causes that behavior and the server version.
Thanks in advance.
[28 Jul 2007 11:31] Kaity G. B.
np i'll give you all the feedback i can,

	right now i have mysqld  Ver 5.0.41 running.  currently from opensuse's packages, but again i've tried the ones right from this site.  there's no specific database.  mysql-query-browser will crash straight from a fresh install and all stock(created) databases.  so i dunno what i could do.  could it be one of the dependancies, even though its compiling fine[when i build it].  i dunno, i'm grasping at straws now.  do you know what the cases are that cause the 'red crossed-circle off death'?  if you know maybe i could try and search down what's causing it(i'm to lazy/busy to try to find its trigger in the source on my own, so if you could help me).  i dunno, again i'm just grasping at straws, so i'm sure i'm just babbling.  thnx for your continued help on this issue.  i'm desparate to get it fixed &mean while i'm going nuts over here.  so again thnx.
[31 Jul 2007 12:50] MySQL Verification Team
Thank you for the feedback. Sorry I don't know what is your problem since
on my side I can't repeat. I will ask to the GUI-Tool developer if he has
a guess about this issue.
[1 Aug 2007 4:34] Kaity G. B.
thank you so much,

	there is also an opensuse meeting tomorrow and i'll see if anyone else on the project is or has had this issues.  i'll update this regardless of what i find out.  hopefully it'll be good news.  i'm freaking out, i really really hope that we can figure out what's happened quickly.  i really do i appreciate all of your help, i can't even tell you how much.  lol, i think typing all of my foreign key constraints may be driving me nuts.
[29 Aug 2007 22:39] Mark V
I'm finding this same problem.
I install from an openSUSE 10.2 buildservice repo.

MySQL Query Browser version: 1.2.8beta
# mysql --version
mysql  Ver 14.12 Distrib 5.0.45, for pc-linux-gnu (i686) using readline 5.1

If I open a QB session by entering a dbname, the QB becomes a zombie process (high cpu use):

10221 mv        25   0 45492  21m  15m R 97.2  1.0   7:09.49 mysql-query-bro

If I open a connection without entering a dbname then the QB opens 'OK'.

What happens after that...?
One step at a time :)
[29 Aug 2007 22:43] Mark V
The OP states:

"if i connect without one and than simply click on any available database.  the database icon is replace with a red circle with a red x through and the process zombies and i have to kill it."

My variation:

if i connect without one and than simply click on any available database.  the database icon is replace with a **re-cycle** circle **only** and the process zombies and i have to kill it.
[1 Sep 2007 18:30] jovan radukin
I can confirm that the bug is present on my Slackware 12.0 system. I've tried to look what is happening and I noticed that the infinite loop occurs in file MQQueryDispatcher.cc in 
MYX_SCHEMA_STORED_PROCEDURES *MQQueryDispatcher::get_sps(const Glib::ustring &catalog,
                                                         const Glib::ustring &schema)

on line 561:
  while(!req->is_complete())

but I can't really say why (req should be complete). Somebody more familiar with source code can probably tell more.
[25 Sep 2007 15:43] Steve Hillier
I have this problem running Slackware 12 as well. I did a packet capture while selecting a schema from the query browser and noticed that it dies when it requests "SHOW PROCEDURE STATUS". Since we are running MySQL 4.0.21 (which this doesn't support procedures) it returns a syntax error message from the server at which point the query browser locks up.
[26 Sep 2007 14:13] Richard Fuller
I have the "if i connect without one and than simply click on any available database.  the database icon is replace with a **re-cycle** circle **only** and the process zombies and i have to kill it." issue on Slackware 12.

This happens whether I build it myself or take the precompiled binaries.

If I dynamically link to gtk 2.8.20 (using LD_LIBRARY_PATH) taken from Slackware 11 instead of the 2.10.13 that comes with Slackware 12 then the issue goes away, and the query browser works fine.
[27 Sep 2007 13:33] Richard Fuller
I've been playing with this a bit more. It hangs in MQQueryDispatcher::get_sps in the while(!req->is_complete()) loop, as reported by another poster.

complete is getting setting to true, then mysteriously being zeroed. Padding the definition in MQQueryDispatcher.h, like so:

        int padding[10240];
        volatile bool complete;
        int padding2[10240];

makes it work reliably, so I guess something is getting written to the wrong place. With less padding it works for opening one schema at a time, but open several and it hangs.

It's mildly suspicious that the loop is commented out of MQQueryDispatcher::get_tables.
[6 Oct 2007 15:10] Jimmy Rentz
Yes, that req->is_complete() loop in MQQueryDispatcher::get_sps() is a problem.  I was able to fix the problem on my Fedora dev system by commenting it out.

The issue is that after the request finishes processing in mysql_query_thread(), the request gets queued up to the _mysql_queue_result queue.  The thread_dispatch.handle_query_result() method is called (via .emit) and pops the req from _mysql_queue_result queue.  req->finish() is called and then the req memory is freed.  This is a race condition because the get_sps() thread tries to poll req->is_complete() in a loop even though the memory might be freed from under it.  This is probably why the req->is_complete() loop is commented out above in get_tables().
[7 Oct 2007 20:25] Sebastiao Correia
I have the same problem on my newly installed system : 
- OpenSuse 10.3
- mysql  Ver 14.12 Distrib 5.0.45, for suse-linux-gnu (i686) using readline 5.2
- MySQL Query browser 1.2.12 version 5.0r12-56.

The problem did not exist on my previous system : 
- Opensuse 10.2
- mysql-query-browser 5.0r4-22.

I could not install the rpm downloaded from your site : mysql-query-browser-5.0r12-1suse10.i586.rpm
since it required libgtkhtml-3.8.so.15

The version of libgtkhtml I have is : 2.11.1-5.
This version does not seem to provide libgtkhtml-3.8.so.15.
Hope this helps.
[16 Oct 2007 20:56] stranger good
Precisely the same problem: 
- OpenSuse 10.3
- mysql  Ver 14.12 Distrib 5.0.45
- MySQL Query browser 1.2.12

Only added sakila sample database to the original distribution
[1 Nov 2007 15:27] mike smith
Mine is the same problem: 
- OpenSuse 10.3 (2 different computers)
- mysql  Ver 14.12 Distrib 5.0.45 (and other versions on other servers)
- MySQL Query browser 1.2.12

Tried from SuSe 10.2 / 10.1 / Windows XP / FC7 and the problem is not present. I was using version 1.1.18 (I think) on suse 10.1

Mike :)
[2 Nov 2007 20:35] Ivan Gonzalez
You can try run this command

mysql-query-browser --update-paths

My full long solution:
1.- I download the general x86_64 bin files from MySQL web with full deps.
2.- Decompressing and run ./mysql-query-browser --update-paths (same command but in decompress folder)
3.- Delete the decompress folder
4.- Now the rpm opensuse 10.3 installed version works OK
5.- ????????????????
6.- Informagic
[6 Nov 2007 17:18] El VerMan
Sorry Ivan, no informagic here... 
I did exactly as you said but the damn thing still freezes over!

The only way is to use the name of the damn DB everywhere in your queries (SELECT 
* FROM dbname.table)
[9 Nov 2007 18:23] Pavel Alexeev
Patch to workaround problem

Attachment: mysql-gui-tools.chema_change_freeze_bug.patch (application/octet-stream, text), 573 bytes.

[9 Nov 2007 18:25] Pavel Alexeev
I have the same problem on Fedora 8 and compiled from src.rpm - mysql-query-brouser freezes on change any schema.

# rpm -q gtk2
gtk2-2.12.1-5.fc8

# rpm -q MySQL-server
MySQL-server-5.1.22-Hu.0.glibc23
(has been built from src.rpm)

Suggestion by Jimmy Rentz fix (completely?) this trouble.

RPMs (both binaries and src) with patches (not only for this BUG) located here: http://hubbitus.org.ru/rpm/MySQL-gui/

Patch is above.
[12 Nov 2007 18:47] El VerMan
How do you apply the patch?
[13 Nov 2007 8:13] Pavel Alexeev
> How do you apply the patch?

Excuse me, El VerMan I don't understand question. This is normal unified patch, which is be able applied as many other, like
patch -p0 -b .bak < mysql-gui-tools.chema_change_freeze_bug.patch
[13 Nov 2007 8:38] El VerMan
i mean, the thing is that "rpm -ba" does not exist in SuSE! am I wrong?
[13 Nov 2007 12:21] El VerMan
Thanks for the "patch" command (I didn't know that) but the question is: How do you re-pack the RPM in SuSE? I've seen many Red hat how-to's rpm.src that state this is done via: rpm -ba file.spec but in SuSE the -b option does not exit.
[13 Nov 2007 12:31] El VerMan
Oh I just found out! sorry for spamming but in SuSE (Mandriva, Fedora) it is something like:

#patch -p0 -b < file.patch
#rpmbuild -ba file.spec
[15 Nov 2007 9:49] Jens Schanz
Patch works fine on OpenSuSE 10.3.
Just download the source "TAR Archive, All platforms" and compile MySQL Query Browser with ./configure --with-gtkhtml=libgtkhtml-2.0.
During compilation there must be another fault in the MySQL Query Browser code.

(mysql-query-browser-bin:17698): libglade-WARNING **: could not find glade file '/usr/local//mysql-gui/common/preferences.glade'

Before you can start the Query Browser you have to link /usr/local/share/mysql-gui/ to /usr/local/ ...
[20 Nov 2007 10:25] El VerMan
dammit, if you have KDE it won't compile... it complains about some Gnome stuff like 
checking for GNOME... 
configure: error: Package requirements (
libglade-2.0
gthread-2.0
libxml-2.0 >= 2.6.2
libgtkhtml-3.0
gtkmm-2.4
) were not met

even if i use the --with-libgtkhtml option.
And I have everything installed from RPM's (i mean the mySQL-Gui tools) so the dependencies should be there.
[20 Nov 2007 11:42] El VerMan
so, basically my problem is: 
#rpm -q libgtkhtml
libgtkhtml-2.11.1-5

#pkg-config --libs libgtkhtml
Package libgtkhtml was not found in the pkg-config search path.
Perhaps you should add the directory containing `libgtkhtml.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libgtkhtml' found

(the same for libgtkhtml-2 or -3 or whatever)
any hints? I have no libgtkhtml.pc anywhere and my PKG_CONFIG_PATH is just empty.
[20 Nov 2007 12:15] Pavel Alexeev
El VerMan, you are wrong.

>if you have KDE it won't compile... it complains about some Gnome stuff like 
Yes, it is complains this stuff, but don't complains Gnome!
I'm build RPMS, which link post before, on Fedora system with KDE and WITHOUT Gnome!

>And I have everything installed from RPM's (i mean the mySQL-Gui tools) so the
dependencies should be there.
Do not confuse binary dependences, and dependences to compile it! To compile, of course, you need development libraries, which comes in additional packages.
[20 Nov 2007 12:29] Pavel Alexeev
El VerMan, as you can see in my SPEC-file, I'm use:

For Fedora Core system:
%define gtkhtml libgtkhtml-3.16

And --with-gtkhtml=%{gtkhtml} for ./autogen.sh || ./configure scripts.

In spec file present other version for various distribution, but it may be obsolets. Just provide correct version of libgtkhtml.

$ rpm -qa '*gtkhtml*'
gtkhtml3-devel-3.16.1-1.fc8
gtkhtml3-3.16.1-1.fc8
[21 Nov 2007 10:19] El VerMan
Yes, of course... the dev packages i didn't check that and of course they were missing.

Thanks P.
[9 Dec 2007 15:38] Georgi Sotirov
I just want to note that Pavel Alexeev's patch has no effect on my Slackware 12.0 system. I'm building MySQL GUI Tools 5.0r12 from source and I think that this patch is  already applied, but the problem persists. I'm ready to give any details that may help resolving this problem, because it's really frustrating.
[9 Dec 2007 16:03] Georgi Sotirov
Please, disregard my previous comment. I was in mistake. It would be nice if this patch gets into the next MySQL GUI Tools release.
[15 Dec 2007 20:12] David T
(also bug 32293)
I had a similar problem with SuSe 10.3 on both 586 laptop and x64 pc
However I seem to have solved it without patching anything:

Download 
mysql-gui-tools-5.0r12-1suse10.src.rpm
mysql-gui-tools-5.0r12-suse10-i386.tar.gz

1. Installed the scr.rpm above...
from the tar.gz then I installed 
2. mysql-gui-tools-5.0r12-1suse10.i586
3. mysql-administrator-5.0r12-1suse10.i586
4. mysql-query-browser-5.0r12-1suse10.i586

The start scripts are here: ***correct***
/usr/bin/mysql-administrator or 
/usr/bin/mysql-query-browser

So that should work (but no desktop icons)

The rpm that puts the gui tools in /opt/mysql-gui-tools/ doesn't work for me... but if you change the properties of the desktop icons that it creates(from /opt/xxx /usr/bin/xxx) to the correct ones above it seems to work.

I couldn't get the x64 package to work - but the i386 seems to work on both machines OK.

So I hope it helps,
david
[24 Dec 2007 15:42] Kaity G. B.
This issue is still happening,

	Even on openSuSE's build service version.  I'm going to be trying the patch in about one hr &if it works I owe you a great big kiss.  I just wanted to check &make sure, before I make anything worse.

	Is Pavel Alexeev's patch the approved patch &/work around?  I'm going nuts, I've missed more personal dead lines than I can count &more than once I've almost lost it not being able to develop.

	I'm incredibly inspired &productive.  &Feeling both are next to impossible given my Generalized Dystonia.  So as grateful as I am for mysql-query-browser; I also feel like I've become reliant on it to be productive &effective at all: as a disabled developer.

	Any ways, to every one who's worked on this; thank you.  I'm anxiously awaiting your response &approved fixed.  phpMyAdmin just doesn't cut it(why no foreign key support?).  Its just missing so much &writing all my queries by hand is killing me.  Thank you, so far, now, &in advance.
[28 Dec 2007 15:05] Pavel Alexeev
David Turkington, do my patch not fix this issue for you?

Kaity G. B., I'm using this patch (not only this) in My own build rpms, as I wrote before. Everything works fine for me. And several people above confirm that it solves the problem. What confirm do you want any more??
[28 Dec 2007 15:09] Pavel Alexeev
Kaity G. B., what distribution do you use? Does my binary rpm not work directly?
[29 Dec 2007 23:12] Kaity G. B.
*w00t*,

	*with tears*.  AMGoddess, thank you Paul.  It took several hours but I finally have mysql-query-browser working again.  I'm so happy &excited again that I'm truly crying.

	Its been so long since I could do any actually productive development &design work that I'd started to give up.  I truly rely on this tool in order to develop my applications, both on line &off.  Now I'm finally able to get back to working full fold on my current project.

	Oh, thank you - thank you so much.  *w00t* - *sqwee* - *giggle*... I'd be doing a happy dance, but there's the whole wheel chair thing... so yeah.  Just hugs &thank you for everything.

	I have websites &podcasts to get back to creating.  YOU ROCK!!!
[2 Jan 2008 11:08] David T
Happy New Year everyone!

Hi Pavel - I didn't use your patch as it seemed to be for version r11.
Apart from that I'm not up to speed with re-compiling anything yet ;)

I gave up with the x64 mysql-guitool version and the 386 version seemed to work OK now. I've been away since the last posting so I'll be able to commit time to it now.
/br
[7 Jan 2008 11:32] Pavel Alexeev
David Turkington, now I build r12 and patch work perfectly on it release.

But, are you sure that your problem is the same, as described in the bug with freeze mysql-query-browser on change scheme? How incorrect path of scripts is relevant to the topic?
[22 Jan 2008 15:04] David T
Hi Pavel,
I'll take a look at the r12 patch.

Yes the freezing mysql-query-browser is the same problem as mentioned here and in other bug reports. When using the icons that are installed with the normal browser install starts a script that seems to have the failure (the circle icon then freezing). By editing what script directory location the icons start, the browser seems to work correctly and no problem is observed.

Running on SuSE 10.3 x64 dual core pentium and 10.3SuSE on 586 laptop.
[23 Jan 2008 6:22] Pavel Alexeev
>1. Installed the scr.rpm above...
for what? If you use binary build, src.rpm not needed.

>from the tar.gz then I installed 
>2. mysql-gui-tools-5.0r12-1suse10.i586
>3. mysql-administrator-5.0r12-1suse10.i586
>4. mysql-query-browser-5.0r12-1suse10.i586

>The start scripts are here: ***correct***
>/usr/bin/mysql-administrator or 
>/usr/bin/mysql-query-browser
Ok. Do you see the BUG described here if it just starts as /usr/bin/mysql-query-browser? In other words, does everything in the started application of mysql-query-browser work correctly and doesn't it freeze on changing schema and on pick "default scheme" when logging in?

>So that should work (but no desktop icons)
So, if it works - congratulations! But desktop icon (if you speak about icon of Desktop managers such as KDE or Gnome, etc.) is completely not relevant to this BUG (read carefully fist description)!
[4 Mar 2008 16:27] David T
Hi,
You are right I didn't need to add the src.rpm - I added it cos I was going to try a compile to see if that sorted out the problem - I didn't in the end. It is in this list as these are the exact steps that worked.

The Icon script that the standard guitools RPM installs in Suse is in
/opt/mysql-gui-tools-5.0/MySQLQueryBrowser.desktop when you look at it in the text editor it looks like this:

[Desktop Entry]
Name=MySQL Query Browser
Comment=MySQL Query Tool
Exec=/opt/mysql-gui-tools-5.0/mysql-query-browser
Terminal=false
Type=Application
Icon=/opt/mysql-gui-tools-5.0/share/mysql-gui/MySQLIcon_QueryBrowser_48x48.png
Categories=GTK;Database;Development;Application

It displays the bug -  we get freezing browser when you try to open a schema, with the litle circle icon etc - like dexcribed in the original bug report.

This one works OK - I had to edit the Exec string
/home/dt/Desktop
[Desktop Entry]
Categories=GTK;Database;Development;Application
Comment=MySQL Query Tool
Comment[en_US]=MySQL Query Tool
Encoding=UTF-8
Exec=/usr/bin/mysql-query-browser
GenericName=
GenericName[en_US]=
Icon=/opt/mysql-gui-tools-5.0/share/mysql-gui/MySQLIcon_QueryBrowser_48x48.png
MimeType=
Name=MySQL Query Browser
Path=
StartupNotify=true
Terminal=false
TerminalOptions=
Type=Application
Version=1.0
X-DCOP-ServiceType=
X-KDE-SubstituteUID=false
X-KDE-Username=

The script located in /usr/bin/mysql-query-browser works OK too
so the porblem seems to be the script that the icons installed with the rpm are pointing at the wrong scripts.

So there are two scripts in different directories. One works OK and the other displays the bug. The icon that the RPM installs points to the wrong script.
[4 Mar 2008 16:32] David T
>Ok. Do you see the BUG described here if it just starts as >/usr/bin/mysql-query-browser?
>In other words, does everything in the started application of mysql-query-browser >work correctly and doesn't it freeze on changing schema and on pick "default >scheme" when logging in?

So to answer this question - when starting the script
/usr/bin/mysql-query-browser in a terminal window things are OK there is no bug.

When I start this one:
/opt/mysql-gui-tools-5.0/mysql-query-browser
I get the bug as described.
[4 Mar 2008 16:37] David T
also When I run the script in atermina window i get a bunch of errors and it takes ages tehn comes up with the database connect dialog box. When log in then click a schema then it dies/hangs - it takes quite a while to come up though.

ion:~ # /opt/mysql-gui-tools-5.0/mysql-query-browser

(mysql-query-browser-bin:20505): Gtk-WARNING **: Unable to locate theme engine in module_path: "qtcurve",
/usr/share/themes/Gilouche/gtk-2.0/gtkrc:30: error: unexpected character `@', expected string constant
Fontconfig warning: line 32: unknown element "cachedir"
Fontconfig warning: line 33: unknown element "cachedir"
Fontconfig warning: "/etc/fonts/conf.d/50-suse-pre-user.conf", line 27: invalid match target "scan"
Fontconfig warning: "/etc/fonts/conf.d/80-delicious.conf", line 18: invalid match target "scan"

(mysql-query-browser-bin:20505): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/immodules/im-xim.so: wrong ELF class: ELFCLASS32

(mysql-query-browser-bin:20505): Gtk-WARNING **: Loading IM context type 'xim' failed
[5 Mar 2008 14:07] Charles Collette
With the latest query-browser running on Slackware 12 I had the same problem. It starts, but does nothing as soon as I try to select a default schema.

After trying a lot of things I finally downloaded mysql-gui-tools-5.0r6-linux-i386.tar.gz (found here in the archive) and this version works perfectly. I don't know what the r12 version does different than this one (can't get r12 to work). Have tried r8, r9, r10 and r11 but all have the same problem.

Will try r13 and on as soon as they appear, but fear the error is persistent.

greatings,
Charles Collette
[24 May 2008 9:38] Richard E
I am using openSUSE 10.3 x86-64 with MySQL GUI Tools 5.0 and while I have not figured out the problem, I have found a way to bypass the freezing.

1. Login to Query Browser without entering the default Schema.

2. In the bottom right corner of the screen will be a box with a tab Syntax, which should be clicked by default. Double click ALTER DATABASE inside the box and wait for about 20 seconds or so until a screen loads (from the double click) in the main area.

3. Now click File > Select Schema at the top and select your database.

It's important that after the main screen loads (with your double click) you hurry and finish the final step. Sometimes it still freezes.
[25 Jun 2008 10:20] Alexander Zakharyash
lspci -vv on Dell inspirton 6000 laptop

Attachment: lspci_vv.zip (application/zip, text), 2.94 KiB.

[25 Jun 2008 10:29] Alexander Zakharyash
I am using Debian Lenny and I have the same problem with freezing of mysql-query-browser on my Dell inspiron 6000 laptop.
Versions:
mysql-gui-tools-common               5.0~rc12-2.1
mysql-query-browser                  5.0~rc12-2.1                     

This issue isn't present on my other PC with the same versions of Debian and mysql*.
Then I have installed Debian Lenny on the VirtualBox on the Dell laptop. On the newly installed system with default mysql databases (mysql, information_schema) Mysql-query-browser is still freezing when I changing schema.
[25 Jun 2008 11:10] Pavel Alexeev
Charles Collette, Richard E, Alexander Zakharyash does my patch solve problem for you?? It is works perfectly for me.
[25 Jun 2008 16:49] Alexander Zakharyash
Thank you very much Pavel. I have tried this patch today and it solved this issue.
[3 Jul 2008 17:00] [ name withheld ]
[27 Sep 2007 15:33] Richard Fuller

has the most constructive comment here so far.

"complete is getting setting to true, then mysteriously being zeroed. Padding the definition in MQQueryDispatcher.h ... makes it work reliably, so I guess something is getting written to the wrong place. With
less padding it works for opening one schema at a time, but open several and it hangs."

Which would mean applying the "patch" doesn't solve the problem. It would just delay it, or cause other crashes in the application or even screw up your data.

And the problem is, I can't reproduce the problem. I've cleared my ~/.mysqlgui and everything works perfectly. If you guys are still getting this problem after clearing the settings, I'll add the hack if it fixes it for you. But I think the real problem is some uninitialized pointer or something.

Recompile with debug symbols, and run under valgrind. Does it run/crashes? Can someone send me the output of valgrind?

When I connect to a schema, the only related item I get is,

==2130== Invalid read of size 1
==2130==    at 0x81436E0: MQQueryDispatcher::get_sps(Glib::ustring const&, Glib::ustring const&) (MQQueryDispatcher.h:70)

==2130==    by 0x81C4F31: MQBaseModule::schemata_fetch_sps(Glib::ustring const&, Glib::ustring const&, MYX_SCHEMA_STORED_PROCEDURES*&) (MQBaseModule.cc:41)

And, the first like is the is_complete call. This kind of points towards the idea that the class wasn't allocated?? Maybe some race condition.

Valgrind found tons of suspicious stuff happening. All of these could be an issue. Could you guys at MySQL fix the valgrind issues please? That may just fix this problem as well.

BTW, I've attached my valgrind output. Browser doesn't crash for me.
[3 Jul 2008 17:01] [ name withheld ]
Valgrind output of specifying default schema in connection (no crash though)

Attachment: l (application/octet-stream, text), 48.99 KiB.

[7 Jul 2008 22:24] Pavel Alexeev
My valgrind output, but GUI does not start from valgrind! Hope if it helps.

Attachment: mysql-query-browser.valgrind (application/octet-stream, text), 10.85 KiB.

[14 Jan 2009 13:20] Susanne Ebrecht
Many thanks for all that feedback.

We are on the way to implement full functionality of MySQL Query Browser into Workbench and won't fix this problem anymore before finishing implementation.

Also Linux is not a supported platform for MySQL Query Browser. More informations about supported platforms you will find here:

http://mysql.com/support/supportedplatforms/tools.html