Bug #30008 AIX 5L - MySQL 5 - not working
Submitted: 24 Jul 2007 15:27 Modified: 3 Sep 2007 17:45
Reporter: Labinot Halilaj Email Updates:
Status: Not a Bug Impact on me:
Category:MySQL Server: Installing Severity:S3 (Non-critical)
Version:5.1.20, 5.0.27 OS:IBM AIX (PowerPC)
Assigned to: CPU Architecture:Any
Tags: scripts/mysql_install_db --user=mysql

[24 Jul 2007 15:27] Labinot Halilaj
Dear all,

My System is:

OS: AIX 5.1
System Model: IBM,7044-170
Processor Type: PowerPC_POWER3
Number Of Processors: 1
Processor Clock Speed: 333 MHz
CPU Type: 64-bit
Kernel Type: 64-bit
LPAR Info: -1 NULL
Memory Size: 256 MB

I'm trying to install mysql-5.1.20-beta-aix5.2-powerpc.tar.gz on it. 
Eventhough, i tried also other versions like: 
   - mysql-standard-5.0.27-aix5.2-powerpc.tar.gz

when it comes to run the mysql_install_db scripts I keep getting these messages.  

How to repeat:
# pwd
# scripts/mysql_install_db --user=mysql
exec(): 0509-036 Cannot load program ./bin/my_print_defaults because of the following errors:
        0509-130 Symbol resolution failed for my_print_defaults because:
        0509-136   Symbol _isinf (number 60) is not exported from
                   dependent module /usr/lib/libc.a(shr.o).
        0509-192 Examine .loader section symbols with the
                 'dump -Tv' command.
Neither host 'monsys' nor 'localhost' could be looked up with
Please configure the 'hostname' command to return a correct
If you want to solve this at a later stage, restart this script
with the --force option

When I try to ping my host:

# ping monsys
PING monsys: ( 56 data bytes
64 bytes from icmp_seq=0 ttl=255 time=0 ms
64 bytes from icmp_seq=1 ttl=255 time=0 ms
64 bytes from icmp_seq=2 ttl=255 time=0 ms

it seems to work fine, I tried searching for a similar problem on the net, but no Luck.

Can anybody point me in the right directions !!!!

With Respect,
[30 Jul 2007 18:56] Valeriy Kravchuk
Thank you for a problem report. Can you just upgrade to AIX 5.2? We do not have 5.1 box available for testing, and thus I am not sure this version is supported.
[30 Aug 2007 23:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[3 Sep 2007 15:50] Joerg Bruehe
Please re-check the name of the package you installed:
It contains the string "aix5.2"

As you are running AIX 5.1, there is no guarantee that a binary built on and intended for AIX 5.2 would run on your machine.
IBM does a good job of providing *upward* binary compatibility
(so a binary for AIX 5.2 will also run on AIX 5.3),
but you try *downward* which cannot work -
it would require IBM to support functions in AIX 5.1 which came only with 5.2

Sorry, your only chance is to upgrade to AIX 5.2,
as MySQL does not support AIX 5.1 any more 
(and neither does IBM: According to
support for AIX 5.1 ended on 01 Apr 2006).

If you cannot upgrade, you can compile MySQL from source yourself.
But note that on AIX we use the IBM compiler, so we cannot give any hints if you should use gcc (or any other compiler).
[3 Sep 2007 17:45] Labinot Halilaj
Thank you for your support,

I fixed the problem by reinstalling the OS. I installed AIX 5.3 and everything is working now.

Thank you