Bug #29954 ODBC is not initializing CHARSET
Submitted: 22 Jul 2007 5:47 Modified: 22 Jul 2007 18:26
Reporter: David Skinner Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / ODBC Severity:S2 (Serious)
Version:3.51 OS:Microsoft Windows
Assigned to: CPU Architecture:Any
Tags: charset, CodeCharge, ODBC

[22 Jul 2007 5:47] David Skinner
Description:
after configuration of standard ODBC connection using ODBC interface, the
connection doesn't actually work, but when CHARSET='utf8' everything seems OK.

MySQL 5.0, MyODBC 3.51, CodeCharge Studio 3.1

How to repeat:
1. Create new connection using ODBC
2. Create new connection using CodeCharge Studio
   Use ODBC Data Source name
   Click OK will deliver error message about an invalid path.

Suggested fix:
Workaround:
regedit
[HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBC.INI\MyODBC]
"CHARSET"="utf8"

This should be an easy fix in the program, just one more variable to initialize.
[22 Jul 2007 18:26] Jim Winstead
This is a duplicate of Bug #29886.