Bug #29873 Linking tables in Access not possible unless root
Submitted: 18 Jul 2007 16:46 Modified: 25 Jul 2007 22:17
Reporter: Jess Balint Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / ODBC Severity:S3 (Non-critical)
Version:3.51.17 OS:Microsoft Windows
Assigned to: Assigned Account CPU Architecture:Any

[18 Jul 2007 16:46] Jess Balint
Description:
When trying to view the list of tables to link the following error is received:

[MySQL][ODBC 3.51 Driver][mysqld-5.0.41-community-nt-log]Access denied for user 'myodbctest'@'localhost' to database 'mysql'

The list of tables is then empty.

The following query is issued:

     57 Query       SHOW TABLE STATUS FROM `mysql`

How to repeat:
Try to link a table with a user that is not root and doesn't have access to the mysql database.
[23 Jul 2007 12:37] Susanne Ebrecht
Hi Jess,

thanks for writing a bug report.
Normally I should ask for your configuration, but I think, all would be fine.
Did you use names with non-7-bit signs?

Regards,
Susanne
[25 Jul 2007 16:04] sigmund burdin
I noticed the same error yesterday after upgrading the Windows ODBC driver from 3.51.16 to v3.51.17.

I had the same experience whether using MS Access 2002(XP) or MS Access 2003 both on Windows XP machines.

In addtion, after uninstalling version 17 and reinstalling version 16 the problem vanshed.  I assume there is enough of a difference between version 16 and version 17 to create this liking problem from within MS Access.

By the way when creating the system DSN in WinXP with MySQL ODBC driver 3.51.17 there was not indication of a problem and the test button declared a successful connection to the MySQL database.  MySQL is served on a Unix box.

Sigmund
[25 Jul 2007 22:17] Jess Balint
Duplicate of bug#28662. This is now raising an error due to the fix for bug#26934. Although not an exact duplicate, this bug shares the same source and fix.