Bug #2980 Installed WinNT MySQL 4.0.18, setup completed, but "mysql.host not found"
Submitted: 26 Feb 2004 13:55 Modified: 26 Feb 2004 14:57
Reporter: Thomas Warfel Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server: Installing Severity:S2 (Serious)
Version:4.0.18 OS:Microsoft Windows (Windows 2000 Server)
Assigned to: CPU Architecture:Any

[26 Feb 2004 13:55] Thomas Warfel
Description:
Downloaded zip file with installer, and ran setup.exe to install.  I chose to install to directory F:\mysql.  I then copied the my-medium.cnf file to the
c:\winnt directory and renamed it to "my.ini", and changed these lines:
 basedir=F:/MYSQL/
 datadir=F:/MYSQL-DATA/

Trying to start mysqld as
 f:\mysql\bin> mysqld-nt --console

Yields:
040226 16:53:01  InnoDB: Started
040226 16:53:01  Fatal error: Can't open privilege tables: Table 'mysql.host' do
esn't exist
040226 16:53:01  Aborting

040226 16:53:01  InnoDB: Starting shutdown...
040226 16:53:07  InnoDB: Shutdown completed
040226 16:53:07  mysqld-nt: Shutdown Complete

F:\mysql\bin>

How to repeat:
Uninstall, delete everything, download and install again to same place.
I'm extremely frustrated because it looks like there's a unix "sh" script to
install the tables, but I have no way to run the setup script to create the tables.

Suggested fix:
Tell in the WinNT instructions how to run the necessary setup scripts.
[26 Feb 2004 14:18] Miguel Solorzano
Please verify if you have the below files in your f:\mysql\data\mysql
directory:

16/02/2004  09:01    <DIR>          .
16/02/2004  09:01    <DIR>          ..
11/02/2004  01:58             8.778 columns_priv.frm
11/02/2004  01:58                 0 columns_priv.MYD
11/02/2004  01:58             1.024 columns_priv.MYI
11/02/2004  01:58             9.088 db.frm
11/02/2004  01:58               153 db.MYD
11/02/2004  01:58             3.072 db.MYI
11/02/2004  01:58             8.641 func.frm
11/02/2004  01:58                 0 func.MYD
11/02/2004  01:58             1.024 func.MYI
11/02/2004  01:58             9.064 host.frm
11/02/2004  01:58                 0 host.MYD
11/02/2004  01:58             1.024 host.MYI
11/02/2004  01:58             8.877 tables_priv.frm
11/02/2004  01:58                 0 tables_priv.MYD
11/02/2004  01:58             1.024 tables_priv.MYI
11/02/2004  01:58             9.806 user.frm
16/02/2004  12:23               204 user.MYD
16/02/2004  12:52             2.048 user.MYI

if the above case, then your datadir is wrong should be:

datadir=f:/mysql/data
[26 Feb 2004 14:43] Thomas Warfel
That corrected it; thanks.