Bug #29708 Mysql .NET Connector installation problems
Submitted: 11 Jul 2007 4:42 Modified: 19 Jul 2007 18:13
Reporter: Bavani Vasudevan Email Updates:
Status: Not a Bug Impact on me:
None 
Category:Connector / NET Severity:S2 (Serious)
Version:mysql-connector-net-5.0.5/5.0.7/5.1.2 OS:Microsoft Windows (XP professional 2002 SP 2)
Assigned to: CPU Architecture:Any
Tags: Input string was not in correct format, installation problems

[11 Jul 2007 4:42] Bavani Vasudevan
Description:
I'm trying to install MySQL connector Net 5.0.5 and getting the following error "Input string was not in correct format",the installation was backed out authomatically. After searched mysql forums/net, i understand it was a bug and already fixed in version 5.0.7. So i tried with version 5.0.7 and 5.1.2. Unfortunately Im getting the same error. I can successfully install version 5.0.5 in frend's pc. Could anybody help me to solve this problems.

system details : XP professional 2002 SP 2,Visual studio 2005,.Net Framework 2.0

How to repeat:
Perform a custom configuration using the wizard.
[11 Jul 2007 21:57] Claudio Biagioli
Same problem here, same configuration WinXP SP2 Italian. I receive the localized error message "Formato della stringa di input non coretto".
[17 Jul 2007 20:05] Claudio Biagioli
Well, I just installed it with no problems on my laptop: XP TablePC Edition.
[19 Jul 2007 9:51] Jyotsna Sonawane
I have the same problem on Windows server 2003 whereas my teammate could install is successfully on XP Kool
[19 Jul 2007 18:13] Reggie Burnett
This is not a bug in the connector or the installer.  The problem is that the perfmon library apparently becomes corrupt sometimes and needs to be restored.  This can be done with the lodctr command line utility.  The following command when run from an admin prompt will restore the library from the system store. After this you can install the product.

lodctr /R