Bug #29695 Assertion failure referencing cygwin when starting mysql
Submitted: 10 Jul 2007 19:42 Modified: 11 Jul 2007 13:10
Reporter: Steve Jakab Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Errors Severity:S1 (Critical)
Version:5.0.41-winx64 OS:Other (Windows 2003 Server IIS 6)
Assigned to: CPU Architecture:Any
Tags: cygwin assertion failure corruption

[10 Jul 2007 19:42] Steve Jakab
Description:
I've got cygwin installed on my dedicated server and have recently installed MySql. The service won't start at the last step of the setup, and I get an error 1067 - process terminated unnexpectedly when I try to start the service manually. Occassionally, the service will start but when I try to do anything with the db, the service bombs out.

Please see attached err.txt file taken from:

C:\Program Files\MySQL\MySQL Server 5.0\data\s15244292.err.

How to repeat:
Install and configure cygwin, let it start its services etc.
Install MySql. Try to get the instance started.
Try to connect using phpMyAdmin - results in big red ERROR
Try again. Get new error - #2003 - The server is not responding
MySql instance (if it was working) stops working - see err file
[10 Jul 2007 19:43] Steve Jakab
Contents of .err file generated when attempting to start MySql 5 service

Attachment: Err.txt (text/plain), 98.62 KiB.

[10 Jul 2007 19:47] Mark Matthews
I don't think this has anything to do with cygwin per-se, our build team uses cygwin to automate the build process, and thus the server is built under a home directory that is under \cygwin\home, and the message you're seeing has to do with the full path name of the source file.
[10 Jul 2007 20:23] Miguel Solorzano
Thank you for the bug report. You are reporting the MySQL server
version 5.0.41-winx64. It is your Windows 2003 a 64-bit box?.
If yes, please see bug: http://bugs.mysql.com/bug.php?id=14649.
Thanks in advance.
[11 Jul 2007 8:00] Steve Jakab
Many thanks for your help with this Miguel - with your help the problem is now sorted :-)

Steve
[11 Jul 2007 12:45] Miguel Solorzano
Thank you for the feedback. Can I assume this bug as duplicate of the
one I have mentioned?. Thanks in advance.
[11 Jul 2007 12:52] Steve Jakab
Hi,
Yes it was. The problem was solved by switching the 64-bit dll to the 32-bit one before running the Instance Config Wizard. Once the wizard ran all the way through, I swapped the DLLs back and re-started the service. All's working a charm now :-)

Cheers,
Steve
[11 Jul 2007 13:10] Miguel Solorzano
Thank you for the feedback. Marking as duplicate of bug: http://bugs.mysql.com/bug.php?id=14649