Bug #29686 Falcon_bug_28040 fails if coupled with Falcon_bug_22181
Submitted: 10 Jul 2007 9:42 Modified: 6 Sep 2007 10:19
Reporter: Giuseppe Maxia Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Falcon storage engine Severity:S1 (Critical)
Version:6.0.1, 6.0.3 OS:Mac OS X (Intel)
Assigned to: CPU Architecture:Any
Tags: falcon, timeout

[10 Jul 2007 9:42] Giuseppe Maxia
Description:
When running the test suite on Mac OS X, Intel based,
test falcon_bug_28040 fails (timeout) if run after test falcon_bug_22181.

Running the test alone succeeds.

ChangeSet@1.2616, 2007-07-09 17:32:09-04:00

=======================================================
Starting Tests in the 'main' suite

TEST                           RESULT         TIME (ms)
-------------------------------------------------------

falcon_bug_22181               [ pass ]            114
falcon_bug_28040               [ fail ]  timeout

Aborting: falcon_bug_28040 failed in default mode. To continue, re-run with '--force'.

How to repeat:
./mtr --skip-im --skip-ndb falcon_bug_22181  falcon_bug_28040

Suggested fix:
N/A
[10 Jul 2007 10:54] Hakan Küçükyılmaz
Verified as described.

Running falcon_bug_22181 succeeds.
Running falcon_bug_28040 succeeds.

Running falcon_bug_22181 and falcon_bug_28040 together fails on Intel/Mac.
[10 Jul 2007 11:44] Giuseppe Maxia
For future reference, to find this bug I used the following shell one-liner:

for T in t/falcon_bug_2[234567]*.test ; \
  do \ 
    TEST=`basename $T .test` ; \
    echo $T $TEST ; 
    ./mtr --skip-ndb --skip-im $TEST falcon_bug_28040 ; \
done
[30 Aug 2007 18:42] Kevin Lewis
Giuseppe, This bug works on my system.  Can you verify with the current Falcon engine?
[30 Aug 2007 20:08] Giuseppe Maxia
Tested again on Mac OSX. 

./mtr --skip-im --skip-ndb falcon_bug_22181 falcon_bug_28040

The problem is still there.

ChangeSet@1.2727, 2007-08-29 23:16:20-05:00

Now the second test hangs indefinitely ( > than 15 minutes and then I stopped it) and the server is not reachable by other clients.

The bug affects only Mac OSX. On Linux, the tests work fine
[4 Sep 2007 14:53] Kevin Lewis
The most recent change sets involved a merge with the current Mysql 5.1 codebase. This must have fixed this bug that Giuseppe was seeing on Mac OS (Intel).
[6 Sep 2007 10:19] MC Brown
Internal change (affects only tests). No documentation needed.