Bug #295 SSL-support is broken under Solaris 8
Submitted: 16 Apr 2003 3:42 Modified: 27 Sep 2008 7:54
Reporter: Marcus Agehall Email Updates:
Status: Won't fix Impact on me:
Category:MySQL Server Severity:S2 (Serious)
Version:4.0.12 OS:Solaris (Solaris 8)
Assigned to: CPU Architecture:Any

[16 Apr 2003 3:42] Marcus Agehall
After configuring MySQL with --with-openssl, compilation fails under Solaris 8. This is due to a include problem in sql/item_strfunc.cc. In that file, crypt.h needs to be included before the openssl-includes and in the released sourcecode this doesn't happen. The resolution is to move the include to the top of the includes.

When the problem above is resolved, the source compiles without any problems. I have, however, not been successfull in connecting to a server compiled with the fix, using SSL. I've tried connecting from a 4.0.12 release compiled under RedHat 7.3 with SSL and I have sucessfully tested the client against another server under Linux using SSL.

I've been using OpenSSL 0.9.7a and 0.9.7b.

How to repeat:
In my case, just configure a vanilla source using the --with-openssl option under Solaris 8.

Suggested fix:
Move the inclusion of crypt.h in sql/item_strfunc.cc so that it is included before any openssl-includes.
[20 Apr 2003 7:08] Alexandre Vaniachine
I believe, that the more proper way to correct for that problem is to modify
the part of the include/my_global.h that deals with crypt/openssl  clash for
other systems.

I have built a 64-bit mysql from the 4.0.12 source with openssl-0.9.7a
using the Forte Developer 7 compiler by disabling crypt support after
the configure step.
I observed no unexpected difference in the output of
  mysql-test-run  --with-openssl --force
compared  to the mysql 4.0.12  built  under RedHat 7.3 with openssl.
[25 Apr 2003 9:18] Michael Widenius
Waiting for more input from user to be able to fix this.
[26 Jun 2003 10:30] [ name withheld ]
This problem appears to be fixed in version 4.0.13. I had the problem in 4.0.12, but, then I tried 4.0.13 and it seems to work fine.
[27 Sep 2008 7:54] Konstantin Osipov
Solaris 8 is not among supported platforms now.