Bug #2949 Implement SSH tunnelling directly in MA
Submitted: 24 Feb 2004 20:43 Modified: 24 Mar 2009 14:57
Reporter: Alex Klymov Email Updates:
Status: Won't fix Impact on me:
None 
Category:MySQL Administrator Severity:S4 (Feature request)
Version:1.0.1a ALPHA OS:Microsoft Windows (windows 2000)
Assigned to: CPU Architecture:Any
Triage: D5 (Feature request)

[24 Feb 2004 20:43] Alex Klymov
Description:
when i use MysqlAdminsitrator to connect to remote database over the ssh tunnel it sense the hostname as localhost and treats it as local - in particular when I go into startup optimization it shows me the default path for the Windows installation (e.g.  c:/Mysql c:/mysql/data). I do not really expect it to save the cnages into remote /etc/my.cnf or wherever it could be but It would be nice instead of "File open error" just give the simple text view window so that i can copy/paste changed parameters to he real server my.cnf

How to repeat:
In any windows SSH client that supports port forwarding (putty would do just fine) create port forwarding:
local->localhost:3306          remote->localhost:3306
And try to connect to the database server. 
After successful conncetion go to the "Startup parameters" dialog window and check base directory input string - it will show C:/MySQL
Try to change some of the startup parameters and hit "Apply changes" - it will show Eror dialog - file open error. In case of choosing "Abort" buttone mysql Administrator application will close.

Suggested fix:
To recognize tunneled conenction you can put "tunneled conenction" checkbox on the connection dialog window, this will indicate that this is remote server not local, thus instead of trying to save startup parameters file app can just display it offering cut/paste option.
[14 Oct 2005 7:50] Mike Lischke
Well, actually this is not a bug. MA cannot know that you are tunneling the connection. However we plan to integrate a tunnelling feature to MA so it does know about it and can act accordingly. Right now, though, it works as designed.
[14 Oct 2005 7:53] Mike Lischke
Oh, sorry, I saw too late it is a feature request. I changed the synopsis to reflect this better.
[24 Mar 2009 14:57] Susanne Ebrecht
Many thanks for writing a bug report. We are on the way to implement full functionality of MySQL Administrator into MySQL Workbench. We won't add this feature request anymore.

More informations about MySQL Workbench you will find here:

http://dev.mysql.com/workbench/