Bug #29410 Fast double click highlighting fails
Submitted: 28 Jun 2007 5:33 Modified: 5 Feb 2009 11:02
Reporter: Jared S (Silver Quality Contributor) Email Updates:
Status: Won't fix Impact on me:
None 
Category:MySQL Query Browser Severity:S4 (Feature request)
Version:1.2.12 OS:Microsoft Windows (Vista)
Assigned to: Mike Lischke CPU Architecture:Any
Tags: highlight, qc, word

[28 Jun 2007 5:33] Jared S
Description:
Fast double click highlight fails

How to repeat:
1. Load Query Browser
2. Type 'bling bling'
3. Try to highlight each word really fast by double clicking each word

RESULT word fails to be hightlighted, users has to wait 1/2 second after first double click
[28 Jun 2007 8:41] Sveta Smirnova
Thank you for the report.

Verified as described.
[3 Feb 2009 23:13] Jared S
Changed to S2.
[4 Feb 2009 15:40] Mike Lischke
Jared, this is not an S2 :-)

Anyway. This is not a bug because the editor supports triple clicks to highlight an entire line (even though it does not highlight the last line, but that's a different thing). So if you do two double clicks where the third click is within the double click time span it ends up as being handled as triple click. Thus the fourth click is not recognized as the second one for the second double click.
[4 Feb 2009 20:09] Jared S
Changed to S4.

SCENARIO
-----
Can't perform manual Search & Replace of specific string quickly and easily.

SUGGESTION:
-----
.Cancel TrippleClick sequence when following conditions are met within millisecond time range of first click:
    - user presses alpha\numeric key during sequnce
    - line index of script tab\query tab changes during sequece.
[5 Feb 2009 10:58] Susanne Ebrecht
I verified this with actual Query Browser.
[5 Feb 2009 11:02] Susanne Ebrecht
We are on the way to implement full functionality of MySQL Query Browser into MySQL Workbench.

There the layout will be different. We won't implement this feature anymore into Query Browser. Because Workbench is different, I will close this now.