Bug #28942 MySQL doesn't write into error log when starts with wrong temporary directory.
Submitted: 7 Jun 2007 10:01 Modified: 3 Oct 2008 18:41
Reporter: Sveta Smirnova Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server Severity:S4 (Feature request)
Version:any OS:Any
Assigned to: CPU Architecture:Any
Triage: Triaged: D5 (Feature request)

[7 Jun 2007 10:01] Sveta Smirnova
Description:
When MySQL starts with @@tmpdir set to not existant directory no error message found in the error log.

If with command line client is easy to find the cause of the issue, GUI Tools could not report error correctly.

How to repeat:
1. Start mysqld with --tmpdir=/path/to/not/existant/dir option
2. Issue "DESC some_table" query

Suggested fix:
Write in MySQL error log about temporary directory does not exists.
[7 Jun 2007 10:11] Sveta Smirnova
See also Bug #28140, Bug #28451 and Bug #27996
[13 Jun 2007 11:02] A Campa
Could you tell me please on how can I fix this problem?
Would it be better to uninstall and reinstall MySQL?

Is there a way during installation to avoid MySQL to select non existant directory?

Regards

Campa
[2 Aug 2007 13:34] Daniel Fischer
Bug#28140 has been marked as a duplicate of this bug.
[3 Oct 2008 18:41] Konstantin Osipov
Duplicate of Bug#9403.