Bug #28738 Error #1030 - Got error 1 from storage engine
Submitted: 29 May 2007 8:34 Modified: 20 Jun 2007 16:14
Reporter: Fraser Ray Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server Severity:S1 (Critical)
Version:4.1.22 OS:Microsoft Windows
Assigned to: CPU Architecture:Any

[29 May 2007 8:34] Fraser Ray
Description:
I copied the raw database files from one hdd to another, re installed windows, re installed sql, copied the forum folder from backup back to the data folder, restarted mysql, unable to access tables.  phpMyAdmin says "Records    Type    Collation    Size    Overhead   " are "in use"

Heres the sql dump:

# phpMyAdmin SQL Dump
# version 2.5.7-pl1
# http://www.phpmyadmin.net
#
# Host: localhost
# Generation Time: May 29, 2007 at 08:28 PM
# Server version: 4.1.22
# PHP Version: 5.2.2
# 
# Database : `forums`
# 

# --------------------------------------------------------

#
# Table structure for table `phpbb_attach_quota`
#

;

#
# Dumping data for table `phpbb_attach_quota`
#

Error

    SQL-query : 

    SELECT  * FROM  `forums`.`phpbb_attach_quota` 

    MySQL said: 

#1030 - Got error 1 from storage engine

[Documentation] ยท [Back]

How to repeat:
selent any table to view.
[29 May 2007 9:08] Valeriy Kravchuk
Thank you for a problem report. Please, send the entire error log. Are you sure you copied all tables from mysql database also?
[29 May 2007 9:40] Fraser Ray
hey, yes, I copied the entire "forums" folder.

The copy and paste is all that phpmyadmin put putted.

Is there something else I can do to get more info?
[29 May 2007 11:17] Valeriy Kravchuk
And what about "mysql" folder? Did you copy it? Please, find .err file in the data directory, if any, and upload it to this report.
[29 May 2007 11:20] Fraser Ray
yes i copied the whole mysql 4.1 folder
[29 May 2007 11:23] Fraser Ray
server.err

Attachment: server.zip (application/x-zip-compressed, text), 7.01 KiB.

[13 Jun 2007 10:23] Fraser Ray
anyone got any ideas at all?????
[20 Jun 2007 16:14] Sveta Smirnova
Thank you for the feedback.

The error log contains many messages like:

070529 20:28:19  InnoDB error:
   8636 Cannot find table nz_hammer/phpbb_attach_quota from the internal data dictionary
   8637 of InnoDB though the .frm file for the table exists. Maybe you
   8638 have deleted and recreated InnoDB data files but have forgotten
   8639 to delete the corresponding .frm files of InnoDB tables, or you
   8640 have moved .frm files to another database?
   8641 Look from section 15.1 of http://www.innodb.com/ibman.html
   8642 how you can resolve the problem.

This seems to be not MySQL bug. So I'll close the report.

Please check if you followed all instructions for moving InnoDB database to another machine which you can find at http://dev.mysql.com/doc/refman/5.0/en/moving.html and http://dev.mysql.com/doc/refman/5.0/en/innodb-backup.html Also check if you didn't renamed database directories while doing backup. If you sure all instructions have been followed and database directories haven't been renamed feel free to reopen the report.