Bug #28664 CHECK TABLE returns confusing message.
Submitted: 25 May 2007 2:17 Modified: 16 Nov 2009 23:18
Reporter: David Snell Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Errors Severity:S3 (Non-critical)
Version:5.1.18 OS:Microsoft Windows
Assigned to: CPU Architecture:Any
Tags: CHECK TABLE, Table upgrade required

[25 May 2007 2:17] David Snell
Description:
CHECK TABLE for both information_schema.global_status and information_schema.session_status produce the following results:

Op: check
Msg_Type:  error
Msg_text:  Table upgrade required. Please do "REPAIR TABLE `C:\WINNT\TEMP\#sql_310_0`" to fix it!

There is, of course, no such table.  The file didn't exist when I checked, but it may be a temporary file that's created and deleted during the CHECK TABLE.

How to repeat:
Run CHECK TABLE on information_schema.global_status or information_schema.session_status
[26 May 2007 9:01] Valeriy Kravchuk
Thank you for a problem report. What exact versioon, 5.1.x, you had used? I was not able to repeat with latest 5.1.20-BK built from sources:

openxs@suse:~/dbs/5.1> bin/mysql -uroot test
Reading table information for completion of table and column names
You can turn off this feature to get a quicker startup with -A

Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 1
Server version: 5.1.20-beta-debug Source distribution

Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

mysql> check table information_schema.global_status;
+----------------------------------+-------+----------+-------------------------
-------------------------------+
| Table                            | Op    | Msg_type | Msg_text
                               |
+----------------------------------+-------+----------+-------------------------
-------------------------------+
| information_schema.global_status | check | note     | The storage engine for t
he table doesn't support check |
+----------------------------------+-------+----------+-------------------------
-------------------------------+
1 row in set (0.01 sec)

mysql> check table information_schema.session_status;
+-----------------------------------+-------+----------+------------------------
--------------------------------+
| Table                             | Op    | Msg_type | Msg_text
                                |
+-----------------------------------+-------+----------+------------------------
--------------------------------+
| information_schema.session_status | check | note     | The storage engine for
the table doesn't support check |
+-----------------------------------+-------+----------+------------------------
--------------------------------+
1 row in set (0.00 sec)
[26 May 2007 9:03] Valeriy Kravchuk
Verified just as described with 5.1.18-beta-community-nt-debug on Windows XP SP2. Note, anyway, that this bug seems already fixed in current sources.
[21 Dec 2007 4:32] Valeriy Kravchuk
I can not repeat the behaviour described neither with 5.1.21 nor with 5.1.22 MySQL binaries. So it is already fixed.
[16 Nov 2009 23:18] Roel Van de Paar
Marked as duplicate of bug #42563