Bug #28607 error 2013 during any query over 30 sec's
Submitted: 23 May 2007 0:31 Modified: 25 Jul 2007 10:18
Reporter: Steven Email Updates:
Status: No Feedback Impact on me:
None 
Category:MySQL Server: Errors Severity:S1 (Critical)
Version:5.0.41 OS:Microsoft Windows
Assigned to: CPU Architecture:Any
Tags: 2013, Lost connection

[23 May 2007 0:31] Steven
Description:
I just moved my db to a new server.  It has the newer mysql on it and when I do any query or repair or anything that takes more than 30 sec's the whole thing fails.  I get errno 2013 lost connection to server during query.  And if I am repairing a table then the table is crashed and have to try again.

How to repeat:
I have a big table that is around 700 meg with 64 meg index and it cannot repair it.  get that error everytime.

Suggested fix:
maybe there is some kinda timeout set in the code not sure.  I have raised all variables to 28800 and still happens.
[23 May 2007 6:18] Sveta Smirnova
Thank you for the report.

Please provide your error log and my.cnf. Also check if you have enoug RAM.
[23 May 2007 19:53] Sveta Smirnova
Thank you for the feedback.

Please upload error log with exact "aborted error". This message can contain useful information.
[23 May 2007 20:23] Steven
Error log

Attachment: error.log (application/octet-stream, text), 1.16 KiB.

[23 Jun 2007 23:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[25 Jun 2007 10:18] Sveta Smirnova
Thank you for the feedback.

There is "sort aborted" error in the error log. It shows you have not enough resources to run query (such as free space in the temporary directory).

Please check if you have enough resources to run this query and if you doubt, provide output of SHOW CREATE TABLE and SHOW TABLE STATUS LIKE for table with which you get the error; output of SHOW VARIABLES LIKE '%tmpdir%'.
[25 Jul 2007 23:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".