Bug #28391 Adding new host for user clears all passwords for that user
Submitted: 13 May 2007 8:04 Modified: 11 Feb 2009 9:57
Reporter: Jason Shuler Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Administrator Severity:S2 (Serious)
Version:1.2.11 OS:Microsoft Windows
Assigned to: Mike Lischke
Triage: D2 (Serious)

[13 May 2007 8:04] Jason Shuler
Description:
After submitting the addition of a new host for the root user, MySQL administrator is suddenly logged out. The root password no longer works.

It turns out MySQL Administrator cleared all the passwords for all hosts for the root user.

When I changed the pasword back for just my hostname, it changed it for all hostnames as well (there is already a bug for this).

This is a very serious and dangerous bug.

How to repeat:
Add a new host for a user.
[14 May 2007 6:43] Valerii Kravchuk
Thank you for a problem report. I can confirm that whenever you set (empty or not) new password for, say, user2 at any host, in MySQL Administrator, it is applied for all entries of user2 (both to user2@'%' and user2@'192.168.0.1', for example). This behaviour can be misleading, as we see from the bug report.
[12 Aug 2008 14:05] William Johnston
The user password is also cleared when you delete a host in version 1.2.12.
[27 Oct 2008 15:23] Riccardo Modolo
I made some verifies. Here the results:

1.2.12
mysql administrator doesn't clear all pass when you add an host but it clears all password when you remove an host and click 'Apply'

1.2.14
i can't reproduce. It seem to be fixed
[11 Feb 2009 9:57] Mike Lischke
Thank you for your bug report. This issue has already been fixed in the latest released version of that product, which you can download at

  http://www.mysql.com/downloads/